Home Forums WoodMart – Premium Template Warning: file_get_contents

This topic contains 11 replies, has 3 voices, and was last updated by Artem Temos Artem Temos 1 month, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #309805

    Ghaso
    Customer

    Dear Sir/Madam,

    I have uploaded a Retail 2 demo and I’m having some problems with the svg icons.

    “Warning: file_get_contents(https://****/wp-content/uploads/2019/05/call-icon.svg): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden
    in /****/domains/****/public_html/wp-content/plugins/woodmart-core/post-types.php on line 725″

    How can I fix it?

    Thank you in advance for your help.

    #309813

    Hello,

    Please try to upload this SVG and let us know if there are any warnings. I attach SVG.

    Most likely something is wrong with the SVG you are trying to upload.

    Best Regards

    Attachments:
    You must be logged in to view attached files.
    #309904

    Ghaso
    Customer

    Thank you for your reply.

    “Most likely something is wrong with the SVG you are trying to upload.” – These SVG files are uploaded together with the Retail 2 demo.

    When I open a direct link to an SVG file (for example: https://****/wp-content/uploads/2019/05/call-icon.svg) it displays correctly.

    #309913

    Hello,

    Please, provide your site admin access to the private area.

    Make the full backup of your site and confirm the permit for us to deactivate the plugins not related to the theme and switch to the parent theme for the while of checking what may take up to 15 minutes.

    Best Regards

    #309924

    Ghaso
    Customer

    Could you please provide me your IP address? I need that to give you the access.

    #309989

    Hello,

    Here is my IP 37.115.27.175

    Please provide access.

    Best Regards

    #310086

    Ghaso
    Customer

    Please check the private area. Thank you!

    Private Content Hidden
    #310258

    Hi,

    It looks like your server blocks requests to load the SVG image with the help of the file_get_contents PHP funciton. You need to disable this restriction mechanism or consult with your hosting provider for help.

    Kind Regards

    #310559

    Ghaso
    Customer

    Hi,

    They are told me that they turned on 2 options:
    – Allow PHP function exec()
    – Allow PHP function eval()

    But unfortunately the problem still persists.
    Do you have any other solutions?

    Thank you!

    #310585

    These functions have no relation to the problem. The problem is that the server blocks some HTTP requests. You can send them the error you mentioned in your first message for a better explanation

    Warning: file_get_contents(https://****/wp-content/uploads/2019/05/call-icon.svg): failed to open stream: HTTP request failed! HTTP/1.1 403 Forbidden
    in /****/domains/****/public_html/wp-content/plugins/woodmart-core/post-types.php on line 725
    #310613

    Ghaso
    Customer

    I see the warning has gone but there is another problem. The icons are not displayed.

    #310632

    Try to re-upload the icon with your own and test how it works. If it is still not visible, then the error is not gone. It is probably just hidden but the problem is still the same.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.