Home Forums WoodMart – Premium Template AJAX Import Error Trying to Import Dummy Content

This topic contains 12 replies, has 2 voices, and was last updated by Artem Temos Artem Temos 1 week, 4 days ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #334685

    LiamTGCS
    Customer

    Hi there,

    I am not sure why this keeps occurring, though I keep getting an error trying to import dummy content/themes. There is something seriously wrong, and it is getting very frustrating.

    AJAX import error. Try to disable all external plugins and run the import again. If it doesn't help, contact our support center for further assistance.

    The dummy content will upload, and then it will freeze up at 70%, once it hits 70%, it then fails, and shortly after it displays the AJAX error above.

    I have done the following troubleshooting:
    • Fresh WordPress + WC + WM Theme install
    • Tried on alternative domains, with and without registering license
    • Tried other imports (some work, some don’t)
    • Disabled Mod Security in the webserver
    • Checked WooCommerce logs (and enabled WP logs, no errors)
    • Confirmed PHP.ini settings as per below

    post_max_size=64M
    memory_limit=2048M
    upload_max_filesize=64M
    max_execution_time=1000

    I was able to eventually get one of the theme/dummy contents uploaded, though because I had to import it twice, all the headers, etc.. were imported twice, so I had to clear/delete all content, and when I try to re-import, it just throws the AJAX error after 70% loading.

    Can someone please point me in the right direction? All the threads I’ve seen on this forum have the same response, and that response is to check the Woodmart installation documentation because something must have been set-up wrong. I can verify that my install is not incorrectly set-up, since I have re-installed multiple times. I have no issues with other themes, so there is something wrong with this theme.

    Private Content Hidden
    #334692

    LiamTGCS
    Customer

    There is something seriously wrong with this theme if this issue keeps occuring. I have disabled all plugins, literally only have WooCommerce & Woodmart Core enabled.

    Sometimes, the theme dummy content will load in, but only if I click on it multiple times, at which point, it has inputted multiple entries of the same content.

    I still can not get the plugin to work, despite only having the core plugins enabled. I have tried all configurations to no avail. Quite disappointed.

    Private Content Hidden
    #334695

    LiamTGCS
    Customer

    PHP Info, please see URL.

    Private Content Hidden
    #334737

    Hello,

    Thank you for purchasing our theme and contacting us.

    The problem is with your hosting timeout parameter of 60 seconds. You need to contact your hosting provider and ask to increase it to 180s. https://www.wpoven.com/blog/how-to-fix-504-gateway-timeout/

    Kind Regards

    #334738

    LiamTGCS
    Customer

    Hi there, please check the PHP file, the timeout parameter is set to 200s on host server, and was set to 60 seconds in the master server. The host server overrides. I have been playing around with the PHP.ini settings to try and get this to work, though I’ve had no luck.

    Please kindly refer to the PHP Ini file (it should now be accessible):

    See private content.

    Still getting the AJAX error, please advise.

    Private Content Hidden
    #334739

    Your server returns 504 Gateway Timeout error after 60s of AJAX request loading. It is not a PHP limit but the server Apache or Nginx.

    #334742

    LiamTGCS
    Customer

    Can you please screenshot the errors you are receiving, is it possible Cloudflare is causing conflicts? I don’t have any issues with other plugins so I’ll need to investigate. Can you please check the PHP Ini and let me know if it is configured properly?

    Please note that I am the webmaster for our server, so I have full administration access to the server. We haven’t got any other issues with other websites or scripts, so there is something conflicting with the Woodmart theme.

    Private Content Hidden
    #334750

    LiamTGCS
    Customer

    I can see the 503 timeout error via the Network console for the admin-ajax.php.

    We don’t have this issue with any other themes, we host many sites on our server.

    Could you please advise the optimal specs for PHP config, as the maximum execution time is over 1 minute (180+ seconds), and it still doesn’t work. We constantly get the AJAX import error.

    #334758

    It is not 503 but 504 server error and here are screenshots from the console

    https://monosnap.com/file/snVLnQYV7e2DM8ZPiLTrfvpOGsSoIU
    https://monosnap.com/file/dGDUhk0JmDpqvCICm9SQCOArKITqrv

    #334769

    LiamTGCS
    Customer

    Yes, sorry, I mean 504 timeout. My bad.

    I am investigating further to ascertain whether this may be a server configuration error, though can you please let me know if there are any prerequisites in terms of PHP Ini config.

    Also, what servers do the plugin connect to – IP & Domains, I will white list these, too.

    #334781

    Our server IP is 138.201.123.145. There are no other requirements for the dummy content except the timeout at least 180s.

    #334800

    LiamTGCS
    Customer

    Issue has been solved.

    Fix: If you are getting an error 504 Timeout error for the admin-ajax.php, and providing you have full Apache/server access, navigate to (or find similar path):

    /usr/local/apache/conf/httpd.conf

    Anywhere in the file, add the following code:

    Timeout 300

    The above code is required as Apache, by default, times out after 60 seconds, contrary to what PHP.Ini settings you have set. You may also need to add this to .Htaccess, too:

    <IfModule mod_dtimeout.c>
    <Files ~ ".php">
    SetEnvIf Request_URI "admin-ajax.php" DynamicTimeout=300
    </Files>
    </IfModule>

    If your instance of Apache has a timeout module loaded, such as the one below, you will need to (in most instances) increase the timeout using the Timeout 300 code above.

    LoadModule reqtimeout_module modules/mod_reqtimeout.so

    #334801

    We are glad that you sorted it out. Let me know if you need any further assistance.

    Have a nice day!

Viewing 13 posts - 1 through 13 (of 13 total)

The topic ‘AJAX Import Error Trying to Import Dummy Content’ is closed to new replies.