Home Forums WoodMart support forum Elements on product page not clickable (Elementor)

Elements on product page not clickable (Elementor)

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #567139

    PD11
    Participant

    Hi,

    I’m currently redesigning my webshop. I’ve removed WP Bakery and added Elementor, to build a better product page. However, some elements on the product page are now not clickable any more, even 1 default Elementor element. I can’t figure out why it’s not clickable.

    In the private content I’ve shared the link to the redesign website and the live website. The elements which are not clickable in the redesign website are:

    – reviews (below product title)
    – accordeon element (none of the accordeon elements are clickable)

    I’m using your other template (Tethys) for another website, also with Elementor. On that website, the accordeon element is fully clickable as it should.

    Could you please help out? Thanks!

    Kind regards,

    Paul

    #567266

    Hello,

    You will have to recreate your site from scratch on Elementor. Switching from one to another builder would not cause data loss. However, all the content created, for example, in WP bakery page builder would be messed up and you will have to recreate it all.

    If you have any questions feel free to contact us.

    Best Regards.

    #567284

    PD11
    Participant

    Hi Aizaz,

    I’m sorry, but I already put 50+ hours in changing and redesigning the website, so I won’t be able to recreate the website from scratch (and also put all products and content in the website).

    There most be another solution, maybe through a developer? I’ve removed all WP Bakery content, so that should not mess up the product page.

    Please help me out here, as beginning from scratch will be too costly and time consuming.

    Kind regards

    PAul

    • This reply was modified 1 month ago by PD11.
    #567384

    Hello,

    Sorry to hear about the inconvenience. Kindly, please share your Site WP-ADMIN Login details in the Private Content field so that we can check this concern on your Site and help you out accordingly.

    Best Regards.

    #567420

    PD11
    Participant

    Hi Aizaz,

    Thank you for helping out. Please find the login details in the private content section. Let me know if you have any other questions.

    Kind regards

    Paul

    #567478

    Hello,

    It is not possible in theme settings to make the star rating clickable like your demo site. Maybe it is coming from a third party on your site. Check back your review widget and check its configuration.

    Best Regards.

    #567507

    PD11
    Participant

    Hi,

    Yes, the review widget is a plugin. It should be clickable out of the box, there is no such setting. I’ll contact the developers of the plugin to be sure.

    Did you manage to check the accordeon element, which are not clickable as well? That is default Elementor. Weird thing is that it’s working in preview mode, but not on frontend.

    thanks,

    Paul

    #567602

    Hello,

    Please update the new version of the theme “WOODMART WordPress NEW: 7.5.1 RELEASED” and update the required plugin and check the option.
    https://xtemos.com/docs-topic/update-the-theme/

    If the issue remains, turn off all of the plugins not related to the theme, refresh your cache, and check if the problem persists.

    Moreover, switch to the parent theme, and recheck it. If the issue remains, let me know and I will check and give you a possible solution.

    Best Regards.

    #568516

    PD11
    Participant

    Hi,

    I’ve updated the theme to 7.5.1 and updated most of the plugins. That did not fix the issue. I’ve changed the theme temporarily to default theme twenty-four and noticed that the accordeon was working. Also, a YouTube element is not visible, which was suddenly visible on the other theme.

    So the issue should be in the theme itself, I reckon. I’ve contacted Elementor support and you should contact them to solve it (via Github) I’ve been told. Or do you have another possible solution?

    The issue with the review stars I could not reproduce as it was not visible at all. But both on Woodmart and Thesys I have the same issue with an Elementor product page

    Kind regards

    #568621

    Hello,

    Can you please share some screenshot where the accordion is not working and also share the page url. So I will check and give you a possible solution. Now I have not seen the accordion element on your site.

    Best Regards.

    #568671

    PD11
    Participant

    Hi,

    I already shared the url before, but please find it again in the private content.

    Kind regards

    #568742

    Hello,

    Please try to use our theme accordion widget and check the issue.
    https://ibb.co/Hrsdb0h

    Best Regards.

    #569082

    PD11
    Participant

    Hi,

    Thanks, that was the solution. Also the YouTube element is now working with another widget.

    #569189

    Sounds Great! that your issue has been solved.

    I’m so happy to hear you are pleased with the Theme and Support. XTEMOS strives to deliver the best customer experience, and it makes our day to hear we have accomplished that.

    We count ourselves lucky to have you as a customer. You can always reach us at any time. We are always here to help you.

    Thanks for contacting us.
    Have a great day.

    Topic Closed.
    Best Regards.

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘Elements on product page not clickable (Elementor)’ is closed to new replies.