Home Forums WoodMart – Premium Template Ajax de inicio de (sesión / registro), fallando

This topic contains 13 replies, has 2 voices, and was last updated by Artem Temos Artem Temos 3 weeks, 6 days ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #172380

    ozni
    Customer

    Hola, un pequeño inconveniente, El ajax de inicio (iniciar sesión/registro), se esta comportando de forma rara, hay momentos en los que obedece y hay otros que no, una vez que un usuario inicia sesión, a veces entra su cuenta y a veces no entra a su cuenta en vez de ello solo le manda a la pagina completa de (inicio sesión/registro), en este ultimo caso empeorando la experiencia de usuario ya que este debe ingresa sus datos dos veces o en todo caso dar dos veces en el botón INICIAR SESIÓN.

    después de rebuscar una solución a este problema me di cuenta que es el tema, por que ya probé deshabilitando todos los cache, descomprimiento todos los archivos etc. ademas este mismo problema sufre el demo del thema woodamrt.

    Resaltar también que este inconveniente se presenta en versión móvil y escritorio.

    Muchas gracias de antemano 😉

    Un cordial y afectuoso saludo para usted.

    Private Content Hidden
    #172443

    Hi,

    Please, describe to us your problems in a bit more details. Attach some screenshots and provide us with a list of steps on how to reproduce it on your website.

    Thank you in advance.

    #172623

    ozni
    Customer

    Hola, para reproducir el problema usted solamente debe entrar en el escritorio y abrir la pestaña ajax de inicio de sesión llenar los datos y darle en iniciar repetir este proceso varias veces y verá que a veces ingresa a la cuenta desde la pestaña ajax y a veces no en caso de no hacerlo redirige a la pagina completa de iniciar sesión asiendo que el cliente tenga que rellenar sus datos de inicio 2 veces.

    intente replicar esto por favor, también el demo tiene este inconveniente, sucede en versión escritorio y móvil.

    si no logra replicar tendré que enviar un video solo que es mas dificil para mi
    gracias por todo.

    saludos.

    Private Content Hidden
    #172650

    We can’t reproduce this issue on our side. Please, send us a video so we can see if we do everything correctly.

    #172873

    ozni
    Customer

    Hola, aqui dejo el video para que pueda revisarlo; marco con un !!! las veces que hubo error,
    notara que solo al final pudo trabajar correctamente el ajax, mencionar que esto también que esto pasa en el demo de woodmart https://youtu.be/F5Nz_nSnU5I

    un cordial y afectuoso saludo

    gracias

    Private Content Hidden
    #172906

    Hello,

    Could you please disable all plugins that are not related to our theme and provide us your admin access so we can check it?
    Also, send us the credentials that you used during the test on the video.

    Thank you in advance

    #173061

    ozni
    Customer

    Hola, ya desactive todos los complementos que podrían causar este inconveniente, probé que el problema sigue, dejo en contenido privado los datos requeridos;

    tambien tengo todos los caches desactivados.

    Por favor intente varias veces con las credenciales ya que algunas veces que funciona a la perfección al inicio, pero luego empieza a estropearse y el ajax no trabaja bien.

    un cordial saludo para usted

    muchas gracias por todo.

    Private Content Hidden
    #173088

    Please, disable WCFM plugin as well and send us your FTP access.

    #173325

    ozni
    Customer

    Hola, aqui dejo datos sobre acceso FTP en privado

    y por favor si ves que el complemento wcfm esta activado, puedes desactivarlo no habrá ningún inconveniente.

    Solo por mencionar, le recuerdo que esto inconveniente tambien pasa con el demo es por ello que lo mas seguro es que sea problema del codigo o script del tema a nivel de cliente, solo desde mi punto de vista.

    un cordial saludo gracias por todo

    Private Content Hidden
    #173370

    Try to add the following PHP code snippet to the child theme functions.php file to do this

    add_filter(
    	'init',
    	function() {
    		if ( isset( $_REQUEST['woocommerce-login-nonce'] ) ) {
    			$_REQUEST['woocommerce-login-nonce'] = wp_create_nonce( 'woocommerce-login' );
    		}
    	}
    );
    #173554

    ozni
    Customer

    Hola, ahora el ajax esta funcionando a la perfección, muchas gracias por lo que hizo,

    un cordial y afectuoso saludo para usted, y mis mayores créditos por el buen servicio:

    que tengas un exelente dia.

    muchas gracias.

    #173587

    Great, we are glad that you like it!

    #178900

    ozni
    Customer

    Hola, me e percatado que con la última actualización el problema a vuelto,

    Por favor haga una actualización para solucionar esto.

    muchas gracias de antemano, un cordial saludo. 😉

    #178923

    Have you added the code to the child theme functions.php file? (not the parent theme)

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.