Home Forums Basel – Premium Template Blog and Portfolio Permalink Structure

Blog and Portfolio Permalink Structure

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #322839

    ryadigital
    Participant

    How do I setup my permalink structure for the blog and portfolio to be the following:

    mywebsite.com/blog/blog-post-title
    mywebsite.com/portfolio/portfolio-post-title

    #323044

    Elise Noromit
    Keymaster

    Hello,

    The permalinks are configured in the Dashboard > Settings > Permalink. This is WordPress functionality and we do not have instructions on how to configure them. You will find a few pre-defined options to chose from.

    If you have any questions please feel free to contact us.

    Best Regards

    #323047

    ryadigital
    Participant

    Hi Elise,

    This is a not a solution to the issue. I purchased the theme to receive the support(3rd purchase) so that I could achieve the aforementioned permalink structure.

    #323048

    ryadigital
    Participant

    The website Plus Packaging uses the basel theme for wordpress. It has the desired permalink structure that I am trying to implement.

    Blog Post
    https://www.pluspackaging.com/blog/business/7-incredibly-clever-packaging-ideas-for-food/

    Portfolio Post
    https://www.pluspackaging.com/portfolio/tissue-paper/caracas-bistro/

    #323188

    Elise Noromit
    Keymaster

    Hello,

    Please provide your site URLs, the URLs you have provided are default URLS.

    Best Regards

    #324207

    ryadigital
    Participant

    I included the site URLs in the private content message body.

    #324450

    Elise Noromit
    Keymaster

    Hello,

    You can set Portfolio project URL slug and Portfolio category URL slug in the Theme Settings > Portfolio.

    The Blog post and categories URLs are configured in the Dashboard > Settings > Permalinks

    If you have any questions please feel free to contact us.

    Best Regards

    #324765

    ryadigital
    Participant

    Elise,

    If I use the settings > permalinks to try and achieve my desired URL structure and use “/blog” then my Portfolio pages will not work as I requested.

    These are not solutions to my issue.

    I would like to have all my posts be the following URL structure:
    /blog/name-of-my-blogpost

    For my portfolio posts, I would like:
    /portfolio/my-portfolio-post-title

    The example website I posted above (plus packaging) is what I am looking to do for my client.

    #324858

    Elise Noromit
    Keymaster

    Hello,

    Please try to write the permalinks in this way: https://take.ms/U8juk

    If you have any questions please feel free to contact us.

    Best Regards

    #325798

    ryadigital
    Participant

    Elise,

    The screenshot you provide is the method I already tried. This does not work as the portfolio post URLS will contain “/blog”.

    I do not mean to be rude but I purchased the theme again to gain technical support. The solutions you are providing are not thought out and we are running around in circles. Can we please move this ticket to a senior engineer.

    #325893

    Elise Noromit
    Keymaster

    Hello,

    You need to configure the permalinks in this way:

    https://take.ms/Cvt6v
    https://take.ms/ujFCH

    Then find this file: wp-content/plugins/basel-post-types/basel-post-types.php and find and replace this line:

    'rewrite' => array('slug' => $portfolio_slug),

    for this line:

    'rewrite' => array('slug' => $portfolio_slug),

    If you have any questions please feel free to contact us.

    Best Regards

    #326423

    ryadigital
    Participant

    Hi the code you provided above to find and replace is the same on both lines. Is that a typo?

    #326438

    ryadigital
    Participant
    Attachments:
    You must be logged in to view attached files.
    #326535

    Elise Noromit
    Keymaster

    Hello,

    Sorry for the mistake.

    Please replace the line: 'rewrite' => array('slug' => $portfolio_slug),

    for this one:

    'rewrite' => array('slug' => $portfolio_slug,'with_front' => false),

    And check the issue.

    Best Regards

    #326661

    ryadigital
    Participant

    Ok I will try that. Can you provide an example of which values I should use for the portfolio project URL and category slugs?

    Should the value be “/portfolio” or “portfolio” without the forward slash (screenshot above).

    Can you provide a screenshot of how the category and project slug should be formatted.

    #326753

    Elise Noromit
    Keymaster

    Hello,

    Please leave this field empty: https://monosnap.com/file/l7bFrbhQeyRdBXJo3H0rlm5YRKvnC8

    If you have any questions please feel free to contact us.

    Best Regards

    #329296

    ryadigital
    Participant

    This solution did not work. It broke my portfolio pages!

    To view my portfolio overview page I have to visit my website.com/blog/portfolio

    The portfolio pages redirect to 404 now.

    #329358

    Elise Noromit
    Keymaster

    Hello,

    Please save Permalinks after changes and check how it works.

    If you have any questions please feel free to contact us.

    Best Regards

    #330867

    ryadigital
    Participant

    Do I have to adjust the second line that handles the taxonomy category as well ($portfolio_cat_slug)?

    /**
    * Create a taxonomy category for portfolio
    *
    * @uses Inserts new taxonomy object into the list
    * @uses Adds query vars
    *
    * @param string Name of taxonomy object
    * @param array|string Name of the object type for the taxonomy object.
    * @param array|string Taxonomy arguments
    * @return null|WP_Error WP_Error if errors, otherwise null.
    */

    Line 524
    rewrite’ => array(‘slug’ => $portfolio_cat_slug, ‘with_front’ => false ),

    #331061

    Elise Noromit
    Keymaster

    Hello,

    Please insert the FTP credentials into the Private content below the message area. Our developers would check deeper.

    Best Regards

    #343909

    ryadigital
    Participant

    Thanks Elise, but seems like what you posted above seemed to work.

    For anyone else who might stumble into this issue:

    Instructions to Achieve URL Pattern:
    yourwebsite.com/projects/your-project-name
    yourwebsite.com/blog/your-blog-title

    1. Go to Settings > Permalink
    -Select custom structure and use this value:
    /blog/%postname%/

    2.) Go to Theme Settings > Portfolio
    -Project Portfolio URL Slug:
    projects

    -Project Portfolio URL Slug:
    projects

    (Remember to hit save!)

    3.) Find this theme file:
    wp-content/plugins/basel-post-types/basel-post-types.php

    Find: ‘rewrite’ => array(‘slug’ => $portfolio_slug),
    Replace With: ‘rewrite’ => array(‘slug’ => $portfolio_slug,’with_front’ => false),

    (There were multiple instances of this find and replace – I believe it occurred twice)
    (You might see the second occurance at Line 524)

    4.) Double check to make sure you saved your Permalinks and Theme Settings!

    #344147

    Elise Noromit
    Keymaster

    Hello,

    Thank you for the shared information.

    If you have any questions please feel free to contact us.

    Best Regards

Viewing 22 posts - 1 through 22 (of 22 total)