Home Forums WoodMart – Premium Template Extra thumbnails loaded and other

This topic contains 51 replies, has 3 voices, and was last updated by Elise Noromit Elise Noromit 1 day, 22 hours ago.

Viewing 22 posts - 31 through 52 (of 52 total)
  • Author
    Posts
  • #131964

    pacman1917
    Customer

    You can reduce the image size in the product page in the Theme Settings > Product page > Images

    11) This way I can change size of image, but not crop.

    We do not have any instructions.

    12) When product Page->Images->Main image click action is set to “none” full sized images are not loaded (https://prnt.sc/ockrwg), so I just need a way to set it to “none” conditionally depending on device type.

    The search icon is white in the page 404

    13) I’ve meant search form on page, not in header – https://prnt.sc/ockuf5

    You can add information by means of EXTRA CONTENT OPTIONS https://xtemos.com/docs/woodmart/product-page-options/#local_settings

    14) As far as I understand this solution should be applied to each product individually which is absolutely not possible

    Where can we check the bug?

    16) Please go to my shop page and try sorting products. I’m temporarily switching to JQuery 3.4.1 to demonstrate the bug.

    This is the way it works. You need to set the background to set the color scheme.

    17) I think this is a bug because text colour and background colour are independent variables for user. Why you are forcing him/her to select background colour if he/she wants to change only text colour.

    You need to set the font in the Theme Settings > Typography for Text font or by means of Advanced typography option, which allows to choose the item from a drop-down or insert your custom CSS class. Please navigate to the Theme Settings > Typography > Advanced Typography.

    18) I don’t want to change my text font site-wide. So your 1st solution doesn’t make sense. As for 2nd solution do you mean I should set up a custom class through advanced typography options?
    Although this can solve the situation, I still think it would be great to have navigation font among other fonts in selection box – it’s much easier for user to select it there than specifying custom class. Please add navigation font to this menu – https://prnt.sc/ocl9wm

    How can we reproduce the problem? What animation do you apply?

    19) just visit my main page you’ll see that slider on top of the page has blank space in the right. I tried different animations and this effect takes place with all of them although amount of blank space is different.

    +20) I had a new bug appeared suddenly – Woodmart information block element doesn’t show svg images anymore, there’s blank space instead of image. I tried replacing old blocks with new ones but this didn’t help… You can check the problem with information blocks on my main page located straight under the top slider – each of 3 text blocks is supposed to have an image to the left of the text.

    #132143

    Hello,

    11. There is no option to crop the image.

    12. Disable all the plugins not related to the theme and check again.

    13. Add this code to Custom CSS

    body .search-by-category .input-dropdown-inner > a,
    body .searchform .searchsubmit:after,
    body .searchform .searchsubmit:before {
    color:white;
    }

    14. There is no option to add globally

    16) This function is not compatible with this JQ version. It is compatible with the JQ version applied in WordPress.

    17) We shall consider that.

    18) Yes, assign a class and configure the font in the Advanced Typography

    19) Deactivate all the plugins not related to the theme and check the issue, if the problem remains, provide your site admin access to the private area.

    20) SVG works well in the Information box. Here is the demo: https://woodmart.xtemos.com/infobox/ deactivate the plugins and check the issue again.

    Best Regards

    #132209

    pacman1917
    Customer

    11) actually this is rather straightforward – https://github.com/woocommerce/woocommerce/issues/19006, looks like you just don’t want to delve into it
    12) do not understand your answer here. I am sure it is possible to disable zoom option conditionally via if( wp_is_mobile() ){ ... } or somehow else
    13) it does not work
    14) I think it can be done via hooks.
    16) please consider updating your code, WordPress won’t stick with outdated JQuery 1.12.4 forever.
    18) this solution works for regular text block but doesn’t work for responsive text block – it uses font selected in options even if special CSS class is assigned. Please check responsive text element within first slide of my main slider.
    19) the problem is still here even if all plugins are deactivated
    20) I am not claiming it’s not working at all in your theme, I am just saying it stopped working on my site. I deactivated all the plugins except those needed by your theme and SVGs are still not shown

    Below are the credentials, please let me know when you finish checking – I need to reactivate plugins ASAP.

    Private Content Hidden
    #132290

    Hello,

    Our support policy does not cover customizing Woocommerce. You can try on your own #11.

    12) I do not see the problem https://gyazo.com/ab267822eb125671cc557e10441fb362

    13) I have provided CSS for search form with Categories select, you have changed, that is why it does not work. Now it works. Placeholder is grey. If I set it white it will be white thought the whole site. It is the nature of the placeholder it cannot be different

    14) You will have to do it on your own. As our policy does not cover such kind of customization.

    16) We keep our theme compatible with WordPress and main plugins.

    18) your screen shows the button settings at the same time you are talking about Responsive text. Add this code:

    body .btn-style-bordered.btn-size-default {
        font-family: "Marcellus SC",Garamond, serif;
        font-weight: 400;
        font-size: 15px;
    }

    19) You are setting the animation on the row containing the slider. The slider does not assume any animation and there occurs a conflict. This slider does not work with row animation. If you want animation you need to use the Slider Revolution.

    20) Please provide FTP we shall check.

    Best Regards

    #132297

    pacman1917
    Customer

    12) Looks like we misunderstood each other. Initially I asked you for a way to NOT load full size product images on product page on mobile and tablet. This is not a bug. I just think full size images are worthless on mobile and tablet because there’s no quality benefit over big enough thumbnail on smaller screens. But they impact user traffic on mobile. I would be glad if you can provide me with solution to either just not load full sized images on mobile/tablet or switch off hover zoom and lightbox functionality on mobile/tablet which should lead to same results (full size images not loaded).
    13) it’s white now, thanks! Your old CSS from previous message doesn’t work even when categories are shown, I switched this after checking your CSS.
    16) great, but one day WordPress will update JQuery version (there’s a ticket for that – https://core.trac.wordpress.org/ticket/37110) and all Woodmart users will have this functionality broken until you provide a fix. Why not fix this in advance?
    18) no, I am talking about text, please see screenshot in attachment
    19) It’s a pity. Please consider fixing it in the future. I really want to get rid off Slider Revolution cause it’s to heavy, loads a lot of JS and affecting performance. Also there’s still a bug with background colour – it is shown only in the far right part of screen – https://prnt.sc/odk8ce
    20) see attachment

    Private Content Hidden
    #132333

    Hello,

    12. Product page and the image size are the functionality of Woocommerce such customization is not covered by our support. Disabling zoom will not reject uploading full-with images moreover there is no zoom on mobile.
    You can hide the bottom for enlargement:

    body .product-additional-galleries {
        display: none;
    }

    16. As soon as WordPress updates, we shall also update. Meanwhile, we run this version to be compatible with other plugins.

    18. Remove the dot in the class field https://prnt.sc/odnysp and try again. Or set this font in Secondary font and choose from the drop-down.

    20. Contact your host support and ask them to enable this function on your server file_get_contents()

    Best Regards

    #132345

    pacman1917
    Customer

    12.

    Disabling zoom will not reject uploading full-with images moreover there is no zoom on mobile.

    Are you sure? When I set Theme settings->Product page->Images->Main image click action to “none” full size images are no longer downloaded unless I click photoswipe icon. That’s why I want to find a method to disable it conditionally.
    18. This way only the colour is applied from my custom style, font family, weight and size are overwritten by styles from dynamic CSS file – https://prnt.sc/odps5t
    19. Please check the bug with slider background image
    20. Done. Here’s their answer: “We have enabled “allow_url_fopen” using cPanel to work file_get_contents().
    Please try to access the same again after clearing the browser cache and let us know the issue persists.”

    #132406

    Hello,

    12)
    The image has the attribute srcset which uploads not original images on mobile and tablet http://prntscr.com/odz73b

    The theme uses image size which is determined by woocommerce_single class. This size can be changed in Appearance > Customize > Woocommerce > Main Image width https://prnt.sc/odza9c

    Product page->Images->Main image click action to “none” does not change the image size which is uploaded

    18)

    Try to use this selector: body my-slider-text

    19) This is not a bug. You are setting the animation on the row containing the slider. The slider does not assume any animation and there occurs a conflict. This slider does not work with row animation. This slider is light and free of animation. If you want animation you need to use the Slider Revolution.

    20) As you see the issue persists, contact the host support again. As I told, I have uploaded the image which works fine on my site and does not work on yours.

    Best Regards

    #132415

    pacman1917
    Customer

    Product page->Images->Main image click action to “none” does not change the image size which is uploaded

    12) This is simply not true. It’s rather strange you don’t know how your own theme works.
    When Product page->Images->Main image click action is set to “zoom” both thumbnails and original images a loaded
    When Product page->Images->Main image click action is set to “none” only thumbnails are loaded, original images are loaded only if I click enlarge button.
    18) result is the same – only colour is applied
    19) OK, is it possible to show some plain color image while slider is being loaded?
    20) SVGs are not working only in infobox Woodmart element, so I don’t want how hosting support would fix it. I suppose something is wrong with theme, not server – when I use SVGs within other elements they are shown.

    #132424

    pacman1917
    Customer

    +21) is it possible to set a link to popup within text element?

    #132434

    Hello,

    12

    Theme settings->Product page->Images->Main image click action to “none” full size images are no longer downloaded unless I click photoswipe icon. That’s why I want to find a method to disable it conditionally.

    Have a look at the screen:

    Original image width is 1000px, Widths set in Appearance > Customize > Woocommerce > Product image > Main image: 1000px –

    Theme settings->Product page->Images->Main image click action to “zoom” Desktop https://gyazo.com/5202e03a40293423d37c35950729faa7 image is uploaded in its original width and it does not change

    Theme settings->Product page->Images->Main image click action to “zoom” Ipad https://gyazo.com/e27f2372a589573d8094715875ed4c7f image is uploaded in its original width and it does not change

    Theme settings->Product page->Images->Main image click action to “none” Desktop https://gyazo.com/5ddb2fb81d850282a07031f8c69fb5ef image is uploaded in its original width and it does not change

    Theme settings->Product page->Images->Main image click action to “none” Ipad https://gyazo.com/3316145ac7b8427e1f0e347f773449b9 image is uploaded in its original width and it does not change

    18) Add this code:

    body .woodmart-title-size-extra-large .woodmart-title-container {
    font-family: "Marcellus SC",Garamond, serif;
        font-weight: 400;
        font-size: 48px;
    	color:red;
    }

    19) Set the background of the row which contains the slider element;

    20) I have tested the image on my site https://gyazo.com/1fb71ce259f4a70e8fc201ea5f5f0a61 I have provided the demo above. SVG works properly with the theme, contact your host support.

    21) If you want to call the popup in the Theme Settings > Shop > Promo popup add the class to the link woodmart-open-newsletter or add Popup element and set button form as a link https://xtemos.com/docs/woodmart/shortcodes-2/

    Best Regards

    • This reply was modified 4 days, 22 hours ago by Elise Noromit Elise Noromit.
    #132448

    pacman1917
    Customer

    12) Most probably this is because your original image has the same size as single product page thumbnail. Please check info in attachment.
    18) Thanks! That worked. As far as I understand this is global CSS setting, so I have some doubts if it can affect some text in other places?
    19) That was my initial idea. But unfortunately it doesn’t work. Regardless color selected as row background there’s white space until slider is loaded.
    20) OK, I’ll try contacting them, but I am afraid they will not provide any help because SVGs are working in general on my site, they are broken only in particular element.
    21) Thanks. But is it possible without button element, just with html? I want some part of text to have a link to popup just like regular link. Is this impossible?

    Private Content Hidden
    #132453

    pacman1917
    Customer

    20) I’ve just checked and it seems that links to SVGs are missing in my html, I don’t think my hoster is responsible for this.
    When I inspect your page i see a lot of code related to infobox SVG:

    <div class="info-svg-wrapper info-icon" style="width: 80px;height: 80px;"><svg version="1.1" id="svg-3717" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
    viewBox="0 0 491.52 491.52" style="enable-background:new 0 0 491.52 491.52;" xml:space="preserve"> <rect x="32.768" y="125.67" style="fill:#FCD462;" width="425.984" height="322.14"/> <rect y="447.8" style="fill:#64798A;" width="491.52" height="30.193"/> <rect x="76.375" y="220.37" style="fill:#DC8744;" width="135.424" height="227.43"/> <circle style="fill:#EBF0F3;" cx="184.934" cy="334.085" r="10.143"/> <rect x="251.443" y="244.808" style="fill:#DC8744;" width="173.082" height="118.886"/> <rect x="261.407" y="254.751" style="fill:#27A2DB;" width="153.211" height="99.041"/> <g> <polygon style="fill:#3AB1DB;" points="332.302,353.784 357.272,254.74 363.992,254.74 339.02,353.784 	"/> <polygon style="fill:#3AB1DB;" points="311.954,353.784 336.926,254.74 351.164,254.74 326.192,353.784 	"/> </g> <path style="fill:#D5D6DB;" d="M10.171,105.394v35.85c0,16.263,13.185,29.448,29.449,29.448s29.448-13.185,29.448-29.448v-35.85
    H10.171z"/> <path style="fill:#D15241;" d="M69.068,105.394v35.85c0,16.263,13.184,29.448,29.448,29.448h0.001
    c16.263,0,29.448-13.185,29.448-29.448v-35.85H69.068z"/> <path style="fill:#D5D6DB;" d="M127.966,105.394v35.85c0,16.263,13.184,29.448,29.448,29.448s29.448-13.185,29.448-29.448v-35.85
    H127.966z"/> <path style="fill:#D15241;" d="M186.863,105.394v35.85c0,16.263,13.185,29.448,29.449,29.448c16.264,0,29.448-13.185,29.448-29.448
    v-35.85H186.863z"/> <path style="fill:#D5D6DB;" d="M245.76,105.394v35.85c0,16.263,13.184,29.448,29.448,29.448s29.448-13.185,29.448-29.448v-35.85
    H245.76z"/> <path style="fill:#D15241;" d="M304.657,105.394v35.85c0,16.263,13.185,29.448,29.449,29.448c16.264,0,29.448-13.185,29.448-29.448
    v-35.85H304.657z"/> <path style="fill:#D5D6DB;" d="M363.554,105.394v35.85c0,16.263,13.184,29.448,29.448,29.448c16.265,0,29.449-13.185,29.449-29.448
    v-35.85H363.554z"/> <path style="fill:#D15241;" d="M422.452,105.394v35.85c0,16.263,13.184,29.448,29.448,29.448s29.449-13.185,29.449-29.448v-35.85
    H422.452z"/> <polygon style="fill:#EBF0F3;" points="130.731,13.527 92.388,13.527 10.171,105.394 69.068,105.394 "/> <polygon style="fill:#E56353;" points="169.074,13.527 130.731,13.527 69.068,105.394 127.966,105.394 "/> <polygon style="fill:#EBF0F3;" points="207.417,13.527 169.074,13.527 127.966,105.394 186.863,105.394 "/> <polygon style="fill:#E56353;" points="245.76,13.527 207.417,13.527 186.863,105.394 245.76,105.394 "/> <polygon style="fill:#EBF0F3;" points="284.103,13.527 245.76,13.527 245.76,105.394 304.658,105.394 "/> <polygon style="fill:#E56353;" points="322.446,13.527 284.103,13.527 304.658,105.394 363.554,105.394 "/> <polygon style="fill:#EBF0F3;" points="360.789,13.527 322.446,13.527 363.554,105.394 422.452,105.394 "/> <polygon style="fill:#E56353;" points="399.132,13.527 360.789,13.527 422.452,105.394 481.348,105.394 "/> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> <g> </g> </svg></div>

    In case of my page there’s only:
    <div class="info-svg-wrapper info-icon" style="width: 65px;height: 65px;"></div>
    Nothing else.

    #132456

    pacman1917
    Customer

    18) I’ve already found a place on my site where the text is affected by this CSS, so this is not a proper solution. I need to apply style to particular text block on slider, not site-wide.

    #132470

    pacman1917
    Customer

    +22) I’ve got one more problem – single image element is no longer shown in far left row in my footer although when i check html block it’s still there.

    #132562

    Hello,

    12) Set the original size in Appearance > Customize > Woocommerce > Product image > Main image

    18) If it effects we shall see how to solve

    19) Set the color background in the slide options under the content.

    20) SVG image is present in HTML code on other sites, contact your host support first.

    22) Do you mean WP Bakery page builder single image? Check it with the default theme.

    Best Regards

    #132580

    pacman1917
    Customer

    12) original size is the size of uploaded image, it can’t be set, you can set only thumbnail sizes
    18) Some headings on inner pages are affected. Of course I can change style there manually, but this is not a proper solution. So please find a way to edit style of responsive text block.
    19) if you do it this way background colour is applied only to text container not the whole slider and it’s loaded late anyway.
    20) I’ve already contacted them. What I should ask them? Do you think they affecting my HTML code? I have no idea how that can happen on their side. SVGs are working correctly if placed via “single image”, pure html or other ways. Please solve this issue, this is getting ridiculous.
    22) I’ve fixed this one – image post ID got corrupted. I have no idea how that could happen, but after removing and adding image it’s fixed.

    #132633

    Hello,

    12) A thumbnail is a kind of image preview it cannot be of the original image by its nature. Our theme does not influence that you will have the same on any theme. Set the original size in Appearance > Customize > Woocommerce > Product image > Main image This option configures the main image on the product page. Set the same size as the original image is. This option works correctly. If you do not like its default operation find a developer who would change it for you as such customization is beyond our support.

    18) Try this code:

    body .wpb_wrapper .my-slider-text .woodmart-title-container {
    font-family: "Marcellus SC",Garamond, serif;
        font-weight: 400;
        font-size: 48px;
    	color:white;
    }

    19) Set the background here https://gyazo.com/4423a6b23193101ed2fb5d47b52c945a

    20) This problem is not caused by our theme, I have demonstrated that not at once.

    Best Regards

    #132678

    Hello there,

    Regarding point #20. We just tested this PHP function again on your server and see that file_get_contents is still disabled. Here is an error from the log https://prnt.sc/of3i68

    Regards

    #132713

    pacman1917
    Customer

    12) I wanted to say that you don’t see that kind of behavior I am talking about on your demo site because your original images are not large enough – they have the same size as your main image size (the one your mentioned in your message, also called “woocommerce_single”) – they were cropped before uploading. As soon as your original images are larger than this size you’ll get your original images loaded along with “main images” for zoom functionality.
    18) thanks, that worked as expected
    19) thanks, that worked too
    20) great, no I at least have some clue to what’s happening. I was told by host that they enabled this option that’s why I kept asking you to dig deeper into this problem. By the way can you please say how I can see this warning message in my dev tools? That’s all I see there – https://prnt.sc/of7p3d

    #132729

    pacman1917
    Customer

    20) finally this one is solved. The problem was caused by conflict between php settings from ‘MultiPHP Manager’ and ‘Select PHP Version’ interfaces of CPanel. But I will be grateful anyway if you tell me how you managed to make dev tools show you error message.

    #132748

    Hello,

    12. This is the nature of zoom functionality. Zoom is the play of image sizes. It cannot be changed.
    20. You need to enable WP_DEBUG in wp-config.php https://codex.wordpress.org/WP_DEBUG

    Best Regards

Viewing 22 posts - 31 through 52 (of 52 total)

You must be logged in to reply to this topic.