Home Forums Basel – Premium Template Javascript not loading on Product Archive Page

This topic contains 5 replies, has 2 voices, and was last updated by Artem Temos Artem Temos 2 weeks ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #213665

    greenlance
    Customer

    I have no idea what’s going on. To be clear, Basel was working just fine in every aspect up until a week or two ago. I’ve been googling around unsuccessfully, trying to identify the issue.
    The issue: Products and the WP admin bar will not load on the Product Archive page (/shop)
    I’ve narrowed it down to JS not loading, because I know the PHP loop is running since it properly counts the number of products that should be displaying (showing products 2, for example)… but the products themselves don’t display and neither does the WP admin bar or anything else that uses ajax or JS.
    It’s also ONLY on this page. I’ve even checked this with the Dokan Vendor Page, and that works just fine. Even the single product pages work. It’s just the product archive page that’s giving me grief.

    The product archive page DOES work with literally any other theme that I install except Basel.

    I’ve troubleshooted the hell out of this. I’ve disabled all plugins, I’ve swapped themes, I’ve re-installed a fresh download of Basel after deleting the installation I had, I’ve flushed permalinks, cleared transients, and I’m not caching anything at any level on this development environment, I can confirm that the shop page is correctly selected in Woocommerce settings, and I’m honestly just out of ideas.

    I really like Basel, but it’s unusable to me like this. Can you please help me figure out what the issue is?

    Any help is greatly appreciated!

    Private Content Hidden
    • This topic was modified 2 weeks, 1 day ago by  greenlance. Reason: additional information added
    #213691

    Hello,

    Thank you so much for purchasing our theme and contacting our support center.

    Could you please disable all plugins that are not related to our theme and provide us your admin access so we can check it?

    Thank you in advance

    #213907

    greenlance
    Customer

    Sure. I’ve put the information in the private content area.
    I’m going to have to ask you to disable the security plugins when you get in there though. I’ve had some trouble recently with hacks, so I’d like to leave the security plugins active until you get in there.

    Private Content Hidden
    • This reply was modified 2 weeks ago by  greenlance.
    #213936

    Our Basel Post types plugin was not installed. Please, check how it works now.

    #213951

    greenlance
    Customer

    Really? That’s what the issue was? Because I’ve been working with this theme for several months now without that plugin installed with no issues. That’s so strange… I wonder why it just started happening?

    Thank you for that. I was tearing my hair out over it.

    #213963

    We don’t know how it worked but this plugin is required for our theme.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.