Home Forums WoodMart – Premium Template Long description corrupted only when logged in

This topic contains 20 replies, has 3 voices, and was last updated by Artem Temos Artem Temos 1 day, 14 hours ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #298139

    tomyech
    Customer

    Greetings to the wonderful Xtemos support team, I hope you’re all doing well.

    Today I discovered an issue that I request your urgent assistance with.

    Please take a look at the following pages *in mobile view*
    https://www.wildguitars.co.il/product/positive-grid-spark-pearl/
    https://www.wildguitars.co.il/product/strandberg-boden-6-dr-titanium/

    When viewing the pages in a private browsing window or without being logged in, the long description appears just as it should. But when logging in, either as a regular customer or as an administrator, the long description appears corrupted with most of the elements being pushed to the right-hand side.

    We have WP Rocket enabled on our website. I know that this cache is turned off when logged in as a customer or admin, but I don’t understand how this can be related to the cache. Even after clearing the cache, the issue persists.

    I’d appreciate your reply as soon as possible. Thanks in advance.

    Best regards,
    Tom

    Private Content Hidden
    #298140

    tomyech
    Customer

    Continuing my previous message, I now see that the long description appears corrupted even when viewing the pages in incognito mode. Earlier today I was able to view them properly. This makes it even more urgent!

    #298153

    Hello,

    Please check how it works with the default WordPress theme just to check whether the issue is with our theme or not.

    Because the product description is woocommerce functionality and our theme doesn’t influence.

    Best Regards

    #298155

    tomyech
    Customer

    Hi Aizaz, thank you very much for the prompt reply.
    I’m not exactly sure how to check something like this with another theme. I’ve activated the “Twenty Twenty-One” theme on our staging website, here is a link to one of the pages:
    https://dev2.wildguitars.co.il/product/strandberg-boden-6-dr-titanium/

    Does this help in any way?

    #298158

    Hello,

    Please deactivate all the third party plugins, activate the parent theme then clear cache and check back.

    If the problem continues then leave all the third party plugins deactivated and tell me then we will troubleshoot with the theme plugins.

    Best Regards

    #298164

    tomyech
    Customer

    Hi Aizaz,
    I have activated the parent theme and disabled all third-party plugins on our staging website, dev2.wildguitars.co.il. I have also completely disabled the cache and asked our web hosting company to clear the WP Rocket folder for safe measure.

    https://dev2.wildguitars.co.il/product/strandberg-boden-6-dr-titanium/

    Right now, the only plugins that are enabled are:
    Classic Editor
    WooCommerce
    Woodmart Core
    WPBakery Page Builder

    Private Content Hidden
    #298281

    Hello,

    Sorry but the password you provided for the main site is not working for the staging and I am unable to see the issue.

    Please provide the login details of the staging site to let me assist you further.

    Best Regards

    #298290

    tomyech
    Customer

    Apologies for that, I had originally given you the login details for the live site but not for the staging site. Please see the private content.

    Private Content Hidden
    #298327

    Hello,

    I have visited your website after logging in and the long description is displayed fine.

    Screenshot for Clarification: https://gyazo.com/fb0393a96cd83faca7b32528574aac4a

    Please clear cache and check back.

    Regards.
    Xtemos Studios

    #298391

    tomyech
    Customer

    Hi Aizaz, it looks like you are only viewing the page in desktop view. In my original message I wrote that the issue only occurs in mobile view. I have uploaded a video for you: https://we.tl/t-GkJ3L6TK8h

    #298419

    Hello,

    I have revisited your website on mobile and the description is working fine on mobile as well.

    Screenshot for Clarification: https://gyazo.com/d9564e0c2c23a7506473075900055213

    Regards.
    Xtemos Studios

    #298436

    tomyech
    Customer

    That’s very odd…I’ve checked in Chrome and Safari and the result is the same. Can you please share what browser and OS you are using?

    #298634

    Hello,

    To debug this issue further we need access to the wp dashboard panel but admin access that you provided is without wd dashboard rights.

    Please provide the login details with the admin rights for the staging site to let us debug the issue.

    Regards.
    Xtemos Studios

    #298636

    tomyech
    Customer

    Apologies again, I forgot to grant admin access to the user. Please try again.

    #298699

    Try to add the following code snippet to the Custom JS area on document ready in Theme Settings to fix this issue.

    setTimeout(function(){
    vc_rowBehaviour();
    },1000);
    #298731

    tomyech
    Customer

    Hi Artem, thanks for jumping in, I hope you’re doing well.
    I see that this snipped has already been added to the “On document ready” section…did do you already do it?

    #298782

    Hi,

    Yes, we have tested this on your website already and probably forgot to remove it. So you can keep that code and check how it works.

    Kind Regards

    #298930

    tomyech
    Customer

    Hi Artem, the following error appears in the console when the code is added to the live site:

    547983389cc61f05badbe4557da33ffd.js:204 Uncaught ReferenceError: vc_rowBehaviour is not defined
    at 547983389cc61f05badbe4557da33ffd.js:204
    (anonymous) @ 547983389cc61f05badbe4557da33ffd.js:204
    setTimeout (async)
    (anonymous) @ 547983389cc61f05badbe4557da33ffd.js:204
    e @ jquery.min.js?ver=3.5.1:2
    t @ jquery.min.js?ver=3.5.1:2
    setTimeout (async)
    (anonymous) @ jquery.min.js?ver=3.5.1:2
    c @ jquery.min.js?ver=3.5.1:2
    add @ jquery.min.js?ver=3.5.1:2
    (anonymous) @ jquery.min.js?ver=3.5.1:2
    s.Deferred.s.Deferred @ 547983389cc61f05badbe4557da33ffd.js:2
    then @ jquery.min.js?ver=3.5.1:2
    S.fn.ready @ jquery.min.js?ver=3.5.1:2
    (anonymous) @ 547983389cc61f05badbe4557da33ffd.js:204

    #299012

    Hello,

    Could you please disable all plugins that are not related to our theme and provide us your admin access so we can check it? Also, add the code so we can see it on your website.

    Thank you in advance

    #299019

    tomyech
    Customer

    Hi Artem, I cannot disable plugins on our live site for obvious reasons. 🙂 Anyway, oddly enough the issue seems to have resolved itself on its own and the long descriptions look great.

    Before we close this thread, I do have another question:
    Ever since the theme update on our live site, I feel like it has become much slower. When viewing the site without being logged in (and the cache being enabled) it is very fast. But the moment that I log in, it is very slow. Before the update, even when being logged in the site was much faster than it is now.

    Can I please request that you make a quick check to see if you find anything out of the ordinary? I know that site speed has a lot of variables and that it can be our web hosting, other plugins, optimizations, etc., but the actual theme update has had a big effect on this (from what I feel).

    Thanks,
    Tom

    #299107

    Do you have this problem with the staging website? Could you please test it with the default theme? If it is much slower with WoodMart, please, disable all external plugins so we can test it.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.