Home Forums WoodMart support forum Page is not mobile friendly

Page is not mobile friendly

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
    Posts
  • #359079

    gksmasonic
    Participant

    Hello,

    I’m having problems with google search, we cannot move further on our digital marketing because google says that our “Page is not mobile-friendly”.

    https://gksmasonic.com/

    Hope you can help us, thank you

    Attachments:
    You must be logged in to view attached files.
    #359104

    Artem Temos
    Keymaster

    Hello,

    Could you please check how it works with some default WordPress themes like TwentyTwenty or WooCommerce Storefront to understand is it our theme issue or not?
    Also, try to delete robots.txt file in your website root folder temporarily and test how it works.

    Regards

    #359133

    gksmasonic
    Participant

    Working well with Default WordPress themes like TwentyTwenty or WooCommerce Storefront.

    I just delete robots.txt file, still not working, the same message as the screenshot above.

    Thank you

    #359174

    Artem Temos
    Keymaster

    Hello,

    Could you please disable all plugins that are not related to our theme and provide us your admin and FTP access so we can check it?

    Thank you in advance

    #359259

    gksmasonic
    Participant

    Hi,

    Right now our website it’s running live and doing sales, it’s a bit difficult to stop it and disable all plugins.

    #359260

    Artem Temos
    Keymaster

    Sorry, but we can’t check it while we can’t disable our theme and additional plugins to find the reason for this problem.

    #359276

    gksmasonic
    Participant

    Ok, we just disable the plugins. thank you

    #359382

    Artem Temos
    Keymaster

    Please, send us your admin access and disable the maintenance mode temporarily.

    #359442

    gksmasonic
    Participant

    Hi,

    I just disable the maintenance mode, which admin access do you need? WordPress admin or FTP admin again?

    thank you

    #359478

    Artem Temos
    Keymaster

    We need your WordPress dashboard access.

    #359485

    gksmasonic
    Participant

    Hi, I just add wordpress info.

    thank you

    • This reply was modified 2 years, 3 months ago by gksmasonic. Reason: Wrong information
    #359489

    Artem Temos
    Keymaster
    #359490

    Artem Temos
    Keymaster

    Please, remove this file from your website temporarily https://gksmasonic.com/robots.txt

    #359495

    Artem Temos
    Keymaster

    And disable the maintenance mode as we asked already.

    Thank you

    #359502

    gksmasonic
    Participant

    I just updated the wordpress info sorry about that, maintenance mode is disable and robots file deleted.

    • This reply was modified 2 years, 3 months ago by gksmasonic.
    #359507

    Artem Temos
    Keymaster

    robots.txt file is still there https://gyazo.com/0efa24a74b7fae7b154e786683ac6070 https://gksmasonic.com/robots.txt
    Also, disable all external plugins temporarily.

    #359511

    gksmasonic
    Participant

    Robots file is deleted, and all external plugins deactivated.

    • This reply was modified 2 years, 3 months ago by gksmasonic.
    • This reply was modified 2 years, 3 months ago by gksmasonic.
    Attachments:
    You must be logged in to view attached files.
    #359555

    gksmasonic
    Participant

    Hello, It’s everything correct now?

    Thank you

    #359636

    Artem Temos
    Keymaster

    There is some kind of optimization/cdn plugin still active on your website that might affect this. Please, disable it first. Here is a screenshot that shows that URLs to CSS files are wrong https://gyazo.com/aba3dae65474b9f4fff90bfc51f88601

    #359701

    gksmasonic
    Participant

    Hi, thank you,

    I don’t understand what’s happening, all the files that I can see on that list, I’m sure that come by default with Woodmart theme. Do you want me to disable all the plugins? Elementor came by default with the theme, is that correct? Widgets? How I can disable those ones?
    Revolution Slider, that comes by default with the theme? Should I disable Woocommerce base? Google fonts?

    Can you be more specific on what I have to do, please? I don’t think this is helpful at all to understand the problem.
    Sorry but, I feel that this support does not reflect the extra charge for support. I feel that you are “helping me” as if it were a free forum.
    Is there a way to address this problem in a better way?

    Thank you

    • This reply was modified 2 years, 3 months ago by gksmasonic.
    • This reply was modified 2 years, 3 months ago by gksmasonic.
    • This reply was modified 2 years, 3 months ago by gksmasonic.
    #359828

    Artem Temos
    Keymaster

    Hello,

    I mean that all these files are optimized by some mechanism either with one of your plugins or with your server. Try to contact your hosting provider and ask to disable all CDN and cache services.

    Kind Regards

    #359842

    gksmasonic
    Participant

    Hi,

    I contacted my provider and they disable all CDN and cache services.

    What’s the next step?

    Thank you

    Attachments:
    You must be logged in to view attached files.
    #359864

    Artem Temos
    Keymaster

    Now it passes the test correctly. Here is a screenshot https://gyazo.com/b65985dba20a79c619b9bc608ef5940b

    #359875

    gksmasonic
    Participant

    Great, Thank you,

    Can we enable the plugins again? Do you have recommendations we need to follow so that this does not happen to again? Is it really necessary to have the CND activated?

    Thank you

    #359972

    Artem Temos
    Keymaster

    The problem is that your CDN seems to be broken and Google can’t load any CSS and JS files from it. You need to consult with your hosting provider for help on this matter. It is not something related to our theme.

    #360015

    gksmasonic
    Participant

    Hi,

    I activated all the plugins and CDN is still deactivated, and still working well on the mobile test.

    Thanks a lot for your time and your advice, I will check it with my provider. Now I understand how CDN works, It’s kind of a code patch.

    Have a great day.

    #360111

    Artem Temos
    Keymaster

    You are welcome! Feel free to contact us if you have any further questions.

Viewing 27 posts - 1 through 27 (of 27 total)

The topic ‘Page is not mobile friendly’ is closed to new replies.