Home Forums WoodMart – Premium Template Single column product page problem

This topic contains 35 replies, has 3 voices, and was last updated by Eric Watson Eric Watson 4 days, 17 hours ago.

Viewing 30 posts - 1 through 30 (of 36 total)
  • Author
    Posts
  • #154980

    pacman1917
    Customer

    Hi, I use single columin images on product page. Recently the layout stopped working properly. Maybe it is related to WooCommerce update to 3.8?
    The issue is that when a variation selected while you try to scroll down through the page only right column with product information is scrolled, left column with product images is not being scrolled beyond 1st image.
    I tried deactivating all plugins and the problem is still here. It’s rather strange but probel appears only for not logged in users, when I am logged everything is OK.
    Please investigate this ASAP because the problem highly affects user experience.

    Private Content Hidden
    #154986

    pacman1917
    Customer

    I’ve just checked in local environment and found that problem is not related to recent WooCommerce update.

    #155006

    Hello,

    I am checking your product and our demo for one column product https://woodmart.xtemos.com/shop/furniture/grand-comfort-chair/?opt=images_col1

    I see the pages work in the same way. How do you expect it should work?

    Best Regards

    #155008

    pacman1917
    Customer

    On the page I provided please select material -> brass and try to scroll.

    #155101

    Hello,

    That was exactly I have done: https://gyazo.com/26f085901dc7b8ef0f99561a40f98d29 and https://gyazo.com/78c01200209ca59233a273641681d522 and I see that they work in the same way.

    Best Regards

    #155114

    pacman1917
    Customer

    Please make sure you select brass and scroll right after loading the page. The bug disappears sometimes after first variation selection. Also it appears only for logged out users.
    I have tested this with different browsers and devices.
    Check following videos:

    Private Content Hidden
    #155208

    Hello,

    Please update your login and password I cannot log in again.

    Best Regards

    #155241

    pacman1917
    Customer

    Looks like this is because some symbols are not shown properply in private content. There’s a “&” symbol in password which was substituted for “&”, remove “amp;” and password will work.

    #155289

    pacman1917
    Customer

    The message was corrupted again, but I hope you got the idea. Did you manage to log in and check what’s going on?

    #155394

    Hello,

    Yes, I have found the proper password and I know that should remove these symbols and I always do. We have entered the site. We need to inspect deeper, please update your FTP access or disable blocking configurations because we cannot log in now.

    Best Regards

    #155519

    pacman1917
    Customer

    Here’s FTP credentials:

    Private Content Hidden
    #155550

    Hello,

    Make sure you have disabled all the blocking configurations. Perhaps your host is blocked for users from certain countries or else. I cannot log in.

    I have tried all ways: quick and manage site ways.

    Best Regards

    #155568

    pacman1917
    Customer

    Let’s get back a bit: are we talking about FTP or wp-admin or both?

    #155635

    Hello,

    Now I am trying to enter FTP and I cannot log in.

    WP-admin access is workable now, I have checked and logged in successfully.

    Best Regards

    #155642

    pacman1917
    Customer

    I’ve just double checked server settings – no IPs are blocked.
    I was able to connect via FTP with these credentials.
    There’s “amp;” again, so please double check that you removed these symbols.

    • This reply was modified 1 week, 2 days ago by  pacman1917.
    #155722

    Hello,

    We checked your site on several devices and we can’t access the site either via FTP or through a browser. We can only access your site using VPN. Our developers are located in Ukraine. Maybe you have to limit access to the country?

    http://prntscr.com/pu7hdf
    http://prntscr.com/pu7f97

    Kind Regards
    XTemos Studio

    #155767

    pacman1917
    Customer

    I contacted host support. They said to me that there are no known IP blocks and asked to provide IP addresses from which you are trying to access the website and the ftp service so that they may investigate the issue.

    #155774

    Unfortunately we do not have a static IP. in this case, could you provide access to your cPanel where there is a file editor.

    Kind Regards
    XTemos Studio

    #155790

    pacman1917
    Customer

    All this is very strange considered your support staff already connected via FTP many times previously.
    I’ve just checked site accessibility from Ukraine and found no problems – https://www.host-tracker.com/InstantCheck/2/3c772e15-3d02-ea11-add0-0003ff7328cc/
    So the problem should be on your side.
    Please try another FTP account:

    Private Content Hidden
    #155825

    Yes, this is very strange, but unfortunately, the developer who is assigned to your topic cannot really connect. Let’s get back to the connection option via cPanel, could you please provide access? Or maybe you can enable the ability to edit files in the admin panel of WordPress?

    Kind Regards
    XTemos Studio

    #155833

    pacman1917
    Customer

    I’ve just installed File Manager WP plugin, please use it for your investigation.

    #155882

    Hello,

    Try adding this code to file woodmart/js/functions.js as shown in the screenshot and disable minify js option in Theme settings.
    https://prnt.sc/puiz2l

    Regarding the indentation problem in the product description, we will add the indentation option in the next update.

    Kind Regards
    XTemos Studio

    #155903

    pacman1917
    Customer

    I added suggested code to functions.js but the bug is still here.
    Please check following:

    Private Content Hidden
    #155953

    The problem that you have shown before on screencast was about product description column disappearing and only product gallery displaying after variation selection. As we can see from now that issue was fixed and we cannot see in anymore your product page.

    We have checked you’re the site again and didn’t see the problem that you have described in your last reply. Could you describe in more detail or better send a screencast or a screenshot where you can see the issue.

    Kind Regards
    XTemos Studio

    #155976

    pacman1917
    Customer

    It’s rather difficult to describe the bug. From time to time it differs. In general there are some glitches realted to images in the left column – either they are are jumping or misaligned badly.
    Please try selecting some variations for different products and you’ll understand.
    Check following videos:

    Private Content Hidden
    #156088

    Hello,

    What we see from your video is that additional variation images on a single product do not have time to load before page scrolling begins. Try to decrease the size of your product images by using lossless image compression and resize images from 2000×1500 to 1200×900 or less.
    It can reduce the weight of your pictures in 3-4 times and have a positive effect on image loading speed when variations were chosen.

    Kind Regards
    XTemos Studio

    #156136

    pacman1917
    Customer

    Check 2nd video – images are fully loaded there. Try yourself and you will see this issue.

    #156239

    Hello,

    Yes, we see a problem and it is very rare and specific, it appears when you turn on at the same time some options such as lazy loading, sticky product, additional pictures of variations, picture style in one column.
    We added a piece of code in the js that fixes the problem, but only if you turn off lazy loading, since you have a placeholder that differs in the aspect ratio of pictures with pictures for the product.
    Add this code to the child theme functions.php to disable gallery-only lazy loading and we will add the yours js fix in the next updates.

    function woodmart_disable_lazy_on_single() {
    	woodmart_lazy_loading_deinit(true);
    }
    
    add_action( 'woodmart_before_single_product_summary_wrap', 'woodmart_disable_lazy_on_single', 5 );
    
    function woodmart_enable_lazy_on_single() {
    	woodmart_lazy_loading_init();
    }
    
    add_action( 'woocommerce_after_single_product_summary', 'woodmart_enable_lazy_on_single', 5 );

    Kind Regards
    XTemos Studio

    #156288

    pacman1917
    Customer

    Thank you very much. Now the bug is fixed.
    Do I understand correctly that I’ll have to keep the code provided in child theme even after update?
    Also I want to draw your attention to the fact that I am using that configuration (single column images + sticky product + lazy loading) for long time and never changed it. But everything was working fine with lazy load turned on, the problem appeared only after recent update. So maybe this this caused by some JS code changes? Can you please investigate this?

    #156298

    Yes, you need to leave this code until we find a universal solution. We will deal with this problem further, as soon as the results are available, we will inform you. We will test this problem with old versions of the theme to find out when it appeared.

    Kind Regards
    XTemos Studio

Viewing 30 posts - 1 through 30 (of 36 total)

You must be logged in to reply to this topic.