Home Forums Space themes support forum Social Authenticators not working

Social Authenticators not working

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #551273

    kashanshah
    Participant

    Hello, I’ve setup both google and facebook login apps, however, an error page occurs when someone tries to log in with google or facebook. Screenshot attached.

    No plugin, other than the required ones by the theme, are activated!

    Attachments:
    You must be logged in to view attached files.
    #551573

    kashanshah
    Participant

    Is there anything else you need to debug?

    #552245

    Luke Nielsen
    Keymaster

    Hello,

    Please send the FTP access to debug the issue.

    Thank you in advance.

    Kind Regards

    #552271

    kashanshah
    Participant

    Please find ftp credentials below.

    #552589

    Luke Nielsen
    Keymaster

    Hello,

    Sorry, but the FTP access that you sent is related to another website. Could you please update it?

    Thank you in advance.

    Kind Regards

    #552913

    kashanshah
    Participant

    Hi Luke,

    Thanks for being careful, but irrespective of the hostname, these credentials have rights only to our website, which is http://www.kazomo.com .

    Let me know if that helps.

    • This reply was modified 2 weeks, 3 days ago by kashanshah. Reason: repalcing compressed image of screenshot
    Attachments:
    You must be logged in to view attached files.
    #553146

    Luke Nielsen
    Keymaster

    Hello,

    Neither themes nor plugins on this site match, so we can conclude that the FTP is linked to another website.

    Screenshots: https://prnt.sc/L6IiQjy82sYc , https://prnt.sc/6QL46VkvW3hJ , https://prnt.sc/i1srvA_jxrnD

    Kind Regards

    #553428

    Luke Nielsen
    Keymaster

    Hello,

    Try to edit the file wp-content/plugins/xts-theme-core/wc-social-authentication/class-wc-social-authentication.php and replace this line
    $opauth = new Opauth( $this->get_config( $response['auth']['provider'] ), false );
    with this one
    $opauth = new Opauth( $this->get_config( strtolower( $response['auth']['provider'] ) ), false );

    And then enable the alt login: https://prnt.sc/NENkXAsGs1ed

    Kind Regards

    #555561

    kashanshah
    Participant

    Hi Luke, thanks for sharing the snippet. I tried doing, but it still doesn’t work.

    Attachments:
    You must be logged in to view attached files.
    #555680

    Luke Nielsen
    Keymaster

    Hello,

    Your Facebook application is not active, check what Facebook shows you: https://prnt.sc/DRDfC40Ou-Ht

    The Google login is not working because the AppId and AppSecret you defined are the same, it’s impossible. Look at our documentation again and pay attention to it. When creating the Google auth you should see Client Id, Client Secret: https://prnt.sc/SfYcFUN7EMjb

    Kind Regards

    #555767

    kashanshah
    Participant

    Thanks, after updating the AppSecret and the code snippet you provided, it worked like a charm. Thanks.

    #556089

    Luke Nielsen
    Keymaster

    Hello,

    You are welcome! In case you need any additional help, I’d be more than happy to assist you.

    Wish you all the best.

    Kind Regards

Viewing 12 posts - 1 through 12 (of 12 total)