Home Forums WoodMart – Premium Template Sort By Button On Category Pages Not Loading All Product Images

This topic contains 20 replies, has 3 voices, and was last updated by Artem Temos Artem Temos 1 month, 3 weeks ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #308949

    Agromo
    Customer

    Hi,

    I’m presently working on a new website that’s almost near completion, but not yet launched. With that being said, I’m currently experiencing the following 2 issues.

    One, an issue with the product photos on the category pages not showing up in totality. For example: If a category page has for instance 150 product images, only about 25 would show up on the page. And whenever that happens, then I would look up at the page’s url on top, and the end of it would show either pages, 2, 3, 4, 5, 6,7, etc. Anything but page 1. This usually happens when I’m at the top of the page, without me even scrolling down and clicking the Load More button.

    Also, I’m not sure if it’s because the website is new and no purchases were made on it yet, but I noticed that “Sort by latest” & “Sort by popularity” options show the same order of the product images in that category. However, the issues always occurred in the pre-programmed “Sort by latest” filter option the category pages are automatically set to, whenever you enter the pages. Then after that when I clicked on the “Sort by popularity” option, all the products are then seen in totality. And if I was to then click on the Sort by latest option, all the photos will finally show up on the page, and be in the same order as the photo in Sort by popularity, when it wasn’t showing all the photos before that.

    I first notice this issue about a month now when I first started uploading the product images on the website up until today. However, since the developer disabled all the plugins not related to the theme earlier today, I don’t noticed seeing the problem since then. Anyway, whenever I’ve noticed this problem happening in the past, I noticed the issue while viewing the website in desktop & tablet views. I assumed that it would be the same in the mobile view as well, but I can’t remember if I experienced it in that view as well.

    The second issue on the website. For the past few day, the product photos on the “New Arrivals” product slider on the homepage & the “You May Also Like” product slider on the single product pages are not all showing the same height like they were originally. Some are longer than others, and sometimes a slight overlapping of the photos or texts at the bottom of the images. And just like the other above issue on the site, when the developer disabled all the plugins not related to the theme earlier today, the product photos on those 2 product sliders became normal again on the tablet view, but the problem is still seen in the mobile view. By the way, I never noticed this issue in the desktop view, only in tablet & mobile view.

    I’m not sure what’s causing these 2 website issues, so I would like you to help me figure it out. For the sake of saving time, since I know you usually ask to have the plugins disabled that’s not related to the theme, I’ve already done that. The site was also backed up already. I’ve provided the login information for you to take a look and see if you could figure things out for me. I hope you’ll be able to solve the problems. If you have any further questions for me, please let me know. Thanks.

    Private Content Hidden
    #309114

    Hello,

    For example: If a category page has for instance 150 product images, only about 25

    As far as I understand you mean the category has 150 and only 25 are shown. This option is changed in the Theme settings > Product Archives > Product gird > Products per page. You can set 500 for example or actually quantity of the products you have and the page will show them all. However, it would not be convenient for user. In addition, you can change “Load More” for the Pagination or infinite scrolling, when the products would appear on scrolling down.

    “Sort by latest” & “Sort by popularity” options

    These are Woocommerce functionality and WoodMart theme does not influence that. You can change the default sorting in the Appearance > Customize > Product catalog.

    As for the product photos, please check this manual: https://xtemos.com/docs/woodmart/faq-guides/image-size-content-alignment-product-grid/

    If you want to have a nice site you need images of the same size and proportionality as there is no option to make them nice. There is only one option to make the theme equal size by cutting that is not always good.

    If you have any questions please feel free to contact us.

    Best Regards

    #309132

    Agromo
    Customer

    Hi,

    I’m sorry, but I don’t know if you actually took the time to read carefully all that I laid out in my thorough explanations of the 2 problems I’m currently facing on my website, especially about the photo size issues.

    I don’t know if you were trying to be sarcastic when you said if I wanted a nice site, I would have to use images of the same size. Like I stated above, all the original product images were the same size, and they were all showing equal in height previously on all 3 websites devices, except for a few days ago when they just started malfunctioning and showing different heights in the tablet & mobile views. And like I stated before, when all the plugins were disabled that were not related to the theme, the product slider images in New Arrivals on the homepage & Related Items on the single product pages started showing the same height again in the tablet view, but in the mobile view, the problem is still happening. However, for some reason, the product slider images in the desktop view were always fine and never affected. So, if I didn’t use “nice” same size pictures on the website, why are all the images on the 2 product sliders for desktop view always showing the same size, and now that the plugins unrelated to the theme were disabled, all the images in the tablet view are now showing the same size again? I guess you didn’t even bother to login to the website to take a look for yourself, even though I left you the login information and asked you for your help.

    You also seemed to completely misunderstood my explanations about the Sort By button issues. I have a women’s clothing & accessories e-commerce website, and all the different categories & subcategories have different amounts of items. I was just giving you an example when I said if a category had 150 items in it, 25 items may sometimes show up. I wasn’t trying to say I want to program a certain amount of items in any of the categories in particular.

    Anyway, something on the website is either affecting Load More button, or the Sort by button(s) from allowing all the items to appear on the category pages sometimes. Most of the items are usually skipped whenever that happened, showing only the last fewer items in that category. You could also tell, because the Load More button is not seen on the page at that time, and the ending or the category page url will show you pages 2,3,4 or higher, but never #1, which it should’ve been if I just entered the page and didn’t click the Load More button yet.

    #309133

    Agromo
    Customer

    The below screenshots are related to the above message.

    #309134

    Agromo
    Customer

    Last screenshots failed. I’m resending them again. They are related to my above message.

    #309135

    Agromo
    Customer

    Below photo #1 related to above message.

    #309294

    Agromo
    Customer

    Hi, can you please get back to my inquiries above as soon as possible, I don’t want to waste another day not having my developer working on the website. I’m trying to make it for my website’s launch date coming up soon. Since the plugins unrelated to the theme were disabled, and the issues with the photos not being the same length and sometimes also overlapping with each other on the New Arrivals product slider on the homepage & Related Items product slider on the single product pages , then its possible that the problem could be due to the theme.

    In general, you seem to take a very long time to get back to my inquiries or following up messages, and sometimes you actually don’t even bother to respond back to them for days, until I send you another message about it. And sometimes when you do respond to my inquiries, you give me misinformation that I have to keep coming back to you about, then it take days just to come to a conclusion about things. If you’re not sure about something, please check with one of your other colleagues about it, or pass the case or inquiry on to someone else. Thanks.

    #309366

    Agromo
    Customer

    Hi,

    This is very unfair & unprofessional. I sent you messages stating that the plugins unrelated to the theme were disabled 2 days ago, plus I also sent you 2 other follow up messages asking you to look into the issues, but I still haven’t heard back from you yet. You responded once after I created the topic, but based on what you were saying to me, it seemed that you didn’t understand what I was trying to explain, or maybe you also didn’t read the entire message. Plus, it also seemed that you didn’t logged into the website to look into the slider image issues & the other issues on my category pages not loading all the product images sometimes when you sometimes entered any of the category pages. I thought it may have been the Sort by button not functioning right, but it may just be the Load More feature skipping most of the product images, and showing only the last few in that category. I don’t usually see the load more button when that happens, and the url showed other page numbers except for page 1.

    Also, seems that other people that are using the same theme are having somewhat similar issues with the Loading of images. I guess the problems I am facing on my category & shop pages are related to the Load More button, based on what that customer was saying they were facing too. I also just read on here when someone else was complaining about the images not having the same height & width on their shop page, even though mine are the product slider images.

    Anyway, I would especially like you to check my website’s mobile view “New Arrivals” product slider on the homepage & “Related Items” product slider images on the single product pages, then you’ll see what I’m talking about. The same thing was also happening on the tablet view, but I haven’t noticed it since disabling the plugin. However, the product slider in the Desktop view was always fine and unaffected. I’m leaving the Login Information to my website again, so please look into it. I have to have the developer resume working on the website several hours from now, because he still have more work to do on it, and my launch date is around the corner. He was not able to make any new updates since plugins and other things were disabled for the past 2 days, going on 3 days in the next several hours.

    Private Content Hidden
    #309390

    Hello,

    We are sorry for the delay. Let’s check every problem one by one.

    1. Product images. We have checked your shop pages using desktop, tablet and mobile devices and all images are shown correctly with the same height
    Dekstop: https://gyazo.com/3b8fa381fad539719e44686e206fb17d
    Tablet: https://gyazo.com/08605dda59d5b88d103adda419953221
    Mobile: https://gyazo.com/74e9eb4bd4cf6ad13a0e6d16e42662b6
    https://gyazo.com/b42b8f0648ffbd1e50d6bd151288c66d

    2. Load more button is working correctly and we don’t see any problems https://gyazo.com/441b1aca6d7417c9361e5ad19fd1e906

    3. As for the sorting mechanism, you are right it is because your website is new and has no orders yet. Please, check how it works with the default WordPress theme to see if it is something caused by our theme or not.

    If we are talking about different things, please, upload your screenshots since we still can’t understand your request. If you can’t upload them here, please, use some cloud service like Dropbox or Google drive.

    Kind Regards

    #309531

    Agromo
    Customer

    Hi,

    I don’t understand. I have explained thoroughly in all my messages over & over again that the height & overlapping issues with the product photos are seen on the product sliders, the “New Arrival” product slider images on the homepage & the “Related Items” product slider images on single product pages, NOT the shop page. Since the plugins were disabled, only the ones in mobile view are still having the issues. The tablet ones are looking normal again. The desktop ones were never affected.

    And as for the Load More issues, since the plugins were disabled, I haven’t noticed the issues with most of the product images not showing up on the category pages when you first entered the pages. By the way, it doesn’t happen literally every single time you enter the category pages, but most times. So if you don’t see the issues the first time you enter a page, leave then come page to the page. Again, you will not see this issue now that the plugins are disabled. I saw it countless times everyday for about a month when the plugins and everything weren’t disabled or switched. Yes, the Load More button is usually not seen when this happens & the URLs on the category pages have either pages 2,3,4 or higher at the ending of them, indicating that lots of photos were skipped automatically and not showing up on the page. As if I clicked the Load More button several times, when I never did, and only just entered the page.

    *** NOTE: It’s very urgent that you look into this as soon as possible, because today is now 3 days since the developer wasn’t able to work on the website and my launch date is almost here. Also, I just recalled that one of your other colleagues gave me a code last week to add navigation dots under on gallery area for the single product page, please check to see if that may have contributed to the problems with the product height & overlapping issues on the 2 product sliders I mentioned above, if you can’t find any other reason for the problem.

    #309536

    Hello,

    Yes, but you didn’t attach the screenshot that we asked about. And we already tested your “New arrivals” twice and don’t see the problem. I have recorded one more video so please watch it and let me know if should test something else https://gyazo.com/5ffa8e1b0063f4aba671b75194b747b0

    As for the load more button, do you mean that it happens only when some third-party plugins are installed, right? Could you please activate them now? And please, record a video of the problem using Loom so we can help you ASAP. That would be much faster and effective than long conversations.

    Kind Regards

    #309555

    Agromo
    Customer

    Hi,

    I tried to send screenshots on here and they kept failing. The other 2 ways you suggested, I’m not familiar with.

    As for you saying you tested the New Arrivals twice and didn’t see the problem, I received a message from my developer this morning my time when he said he fixed the problem. He forgot to fix the other product slider issues on the single product page as well at the time he fixed New Arrivals. Had you looked at that one even an hour ago on the mobile view like I stated several times, you would’ve seen it for yourself. Anyway, I reminded him of that one as well, and he just fixed that one also.

    The developer told me that it was due to a code one of your other colleagues gave me to add “…” when a product name gets too long, below the images. He said the code was not inclusive on the New Arrivals product slider & Related Items product slider, so for some reason it created the issues with the product heights and overlapping. He said he added the following code to fix the problem:

    .product-grid-item { max-width: 100%; }

    As for the issues with the category pages, I also explained that all the unrelated plugins to the theme were disabled a couple of days ago, so the problem is not seen now. I thought you would’ve enabled them back if you needed to, in order to test things out for yourself. I also thought that based on my multiple thorough explanations, since I couldn’t upload the images, that you would get the idea of what I was trying to explain. Anyway, I’ll ask my developer if he could resize the image files of the screenshots for me, so I could send you the screenshots. Thanks.

    #309561

    Agromo
    Customer

    Hi, these 5 images were old screenshots I took of the category page issues. I found a website online to resize the images, I hope they get uploaded this time.

    Attachments:
    You must be logged in to view attached files.
    #309568

    Agromo
    Customer

    And even though the problem with the images on New Arrivals & You May Also Like (Related Items) were fixed by the developer, this is what the images looked like on those 2 sliders with the heights being different and the overlapping issue as well. If you didn’t see my last message with the screenshots above, please check that one as well. Thanks.

    Attachments:
    You must be logged in to view attached files.
    #309657

    Hello,

    As far as we understand, the problem with images was caused by your custom code added by your developer right? So it is not a theme bug or issue?

    If the problem with the “Load more” button happens because of some of the third-party plugins that are not related to our theme then you need to enable them one by one to identify which of them causes this problem.

    As for your screenshots about the pagination, it is how the WooCommerce works by default and everything are correct there. You can check this with the default WordPress theme and see the same.

    Kind Regards

    #309775

    Agromo
    Customer

    Hi,

    Like I stated in my one of my messages yesterday, the problem with the images overlapping & having different heights on the 2 product sliders were due to the custom code one of your colleagues gave to me when I inquired about how to add “…” (dot dot dot) when a product name gets too long below the images, instead of it continuing to the next line. The small code I showed you yesterday was what the developer said he used to fix the problem. He wanted me to show it to you. He said the code one of you originally gave me didn’t cover the images in those 2 sliders that were having the issues, so it caused the images to distort. Nowhere else on the website had those issues.

    As for what you said about the screenshots and how pagination works, I’m guessing you still didn’t get what I explained several times before, or try to convey through the screenshots.

    If I’m just entering a category page, and still at the top of the page without scrolling down or pressing the load more button, then the URL ending should say page 1, and the top of the page that has the number of items on that category page should show for example: 1 – 24 of 100, not 87 – 100 of 100, and the ending of the page’s URL should NOT say page 3 when I’m just entering a page without even scrolling down or pressing the Load More button. In Which the Load More button is usually missing when that usually happens. I think you don’t see the Load More button during this period, because most of the products (first sets of images) in that category doesn’t load, it only loads the last set of images at the ending of that category, in which the Load More button wouldn’t be seen anymore, even if it’s working correctly. I don’t think there’s any better way to explain this.

    I will see if this is really a plugin related issue by observing if this is still happening now that the plugins are enabled again, and if the problem ceases when certain plugins are disabled. If the problem persists, then it could be related to the Load More or sorting features. By the way, is Pagination & the Load More button related to the theme?

    #309840

    Hello,

    Pagination is a default WooCommerce functionality so you can check this with the default WordPress theme. As for the load more button, it is actually using the same pagination mechanism but instead of reloading the whole page it loads products with AJAX and simply puts after existing products. And the URL changes as well. It is not a bug but the way it works.

    Kind Regards

    #309925

    Agromo
    Customer

    Hi,

    I wasn’t trying to imply that the URL showing the page number on top was an error or bug. However, the page number on top in the URL should say page 1 if I’m just entering a category page without scrolling down, or pressing the Load More button. Even though I’m not a developer, I know my own website and know what I’m being faced with for about a month now since uploading the product images, and what is happening it definitely not normal. In fact, as a person trying to do business, it could possibly cost me potential profits if the customers are just entering a category page, 103 items were setup under one of the categories, but only 7 items showed up on the page, and there is no Load More button to press and see the other remaining 96 items in that category. Well, that’s literally what just happened to me again today. I guess I will have to hire a professional to see if there is a bug or what the problem is, so they could fix it, since I can’t seem to figure out the cause. I can’t have a new website get launched with this kind of problem. It will not only cost me potentially profit, but it’s a little bit embarrassing also to have a brand new website with errors. See screenshot. Thanks anyway.

    • This reply was modified 1 month, 3 weeks ago by  Agromo.
    Attachments:
    You must be logged in to view attached files.
    #310043

    Hello,

    We test your website again and again but don’t see the problem. We visit the product category page and always see correct number of products on the first page https://gyazo.com/a81ad031139522c943e360de94f5e1bc
    Is there an exact algorithm for how to reproduce the problem?

    Kind Regards

    #310063

    Agromo
    Customer

    Hi,

    I’m currently facing another issue on my website that occurred several hours ago. The issue seems to be only visible when viewing it from my iPhone. When the developer is viewing the mobile homepage on his Android phone, he told me that everything appeared fine. He edited some texts on the mobile homepage Gift Card banner prior to me noticing the problem. Yes, he also did other small edits on the homepage as well, like editing the texts in The Arrivals title from its previous name. Doing something that small created some issues on the website as well, where everything below the The Arrivals section went blank. And this visibility issue was also something only seen through an iPhone not an Android phone. It took several hours for us to solve the problem and the issue was eventually fixed. Because a couple of months ago I experienced the same issues. Back then it had something to do with the title in one of the homepage sections, and this time it also had something to do with another homepage title that was edited. The developer had to recreated the title over then the problem was fixed. However, this may be unrelated and just a coincidence, but the Gift Card banner started showing double images of the gift card, when it was originally only one card image on the banner. We can’t seem to figure this one out though, so I would like some help from you to help figure things out. Awaiting your reply. Thanks.

    #310077

    Hello,

    We have just tested your home page and it has no problems on mobile devices including iPhone. Here is a screenshot https://gyazo.com/d993f4df6fc47c794639e25d06e166e3

    Kind Regards

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.