Home Forums WoodMart – Premium Template The headers of my home page in two languages is different.

This topic contains 21 replies, has 2 voices, and was last updated by Elise Noromit Elise Noromit 3 weeks, 6 days ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #96545

    After I translated my homepage with WPML, the headers are different.

    Private Content Hidden
    #96557

    Hello,

    Taking into consideration that you need two different headers for different languages your headers may be different. You need to configure or recreate them both in the same way https://xtemos.com/docs/woodmart/header-builder/

    Best Regards

    #96713

    I know how to build a new header, but I don’t know how to set the header to the translated page.

    #96724

    Hello,

    1. Find it in WPML Strings as shown on the screen: https://prnt.sc/kgxj71
    2. Insert the Header ID in the translation, taken from here: http://prntscr.com/kgxkel

    Best Regards

    #96746

    It just works on default header.
    I have used two headers, the header of the home page is not a default header.
    How to find all headers in WPML setting?

    #96772

    Hello,

    Enter the header you have set as default and find this ID http://prntscr.com/lwhbdx

    Navigate to WPML > Strings trasnslation > enter into the search > find http://prntscr.com/lwhcj1

    Best Regards

    #96778

    I could found the default header id in the WPML Strings translation settings.

    But I couldn’t found the headers’ id which are set to the default header in the settings of WPML strings translation.

    I need to set a header for the translated page which don’t go with the default header originally.

    #96797

    Hello,

    Here is how the default header differs from others http://prntscr.com/lwi97u

    Take into consideration that each page has the option to set the custom header which may be different from the default. https://xtemos.com/docs/woodmart/options-for-pages/

    But I couldn’t found the headers’ id which is set to the default header in the settings of WPML strings translation.

    WMPL does not set the default header it just correlates the translations.

    Best Regards

    #96806

    Oh I think we know it better now.

    Sorry I gave you a wrong clue, I need to correct this:
    I could find the header id belongs to the default header in the setting of WPML string translations. And I couldn’t find the other header ids which don’t belong to the default header.

    Private Content Hidden
    #96844

    Hello,

    You need to create a header for translation http://prntscr.com/lwkxoh you will find it in the list of headers (I show from my site) Enter it and find this part and copy it https://prnt.sc/lwhbdx

    Best Regards

    #96845

    Hello,

    Thank your efforts on this case!
    I need to re-submit this issue, pls check the private content

    Private Content Hidden
    #96854

    wait a moment, I am making some screenshots

    #96868

    HI,

    1. The default header and ID
    Header Base-shop page / header_530306

    I just could found header_530306 in the WPML string translations.

    Some information in private content and screenshots.

    Best wishes!

    Private Content Hidden
    Attachments:
    You must be logged in to view attached files.
    #96876

    admin access

    Private Content Hidden
    #96924

    Hello,

    Here is your default header: http://prntscr.com/lwosk4 As I show you on the screens you need to take this part header_530306 and insert into the search https://gyazo.com/25e1ff71a06f655834f4dc0867cb618d

    Then you need to insert the ID of each header for each language accordingly http://prntscr.com/lwotz6

    Best Regards

    #97749

    As your guide, It’s just able to set the default header’s translation, and couldn’t set the other headers’ translation.
    I tried to add the other headers’ strings to String Translation tab from Translate texts in admin screens tab, but the other headers’ strings didn’t present in the String Translation tab.

    Attachments:
    You must be logged in to view attached files.
    #97819

    Hello,

    Other headers are set in the custom header field of the page option https://xtemos.com/docs/woodmart/options-for-pages/

    You just set different custom headers for different languages in pages

    You need to synchronize your menus in WPML.

    Best Regards

    #97966

    Yes, I set a header to my home page, and set another header as default, It works well.
    and I synced the translated part of the menus.
    And I set the translated header for my default header, it worked.
    The problem is how to set the translated header for my home page which don’t go with the default header.
    Pls help me.

    Private Content Hidden
    #97997

    Hello,

    You translate the default header via String Translation as was described above.

    If you want to apply the default header, you need to set “inherit” in both: the source page and in the translation page.

    If you want to apply a custom header, you create two custom headers for each language and set one custom header in the source page and another custom header (translated) in the translation page in the Custom Header drop-down of the Page options https://xtemos.com/docs/woodmart/options-for-pages/

    Best Regards

    #98048

    So pls give me a way to find the translation page, and edit it

    #98051

    I found a way to edit the translated page:
    1. login in to the wp-admin page
    2. In the same browser, open the translated page
    3. there are some options at the top of the translated page, select the option: edit page.
    4. then designate the custom header

    And are there some other ways to edit translate pages?

    #98094

    Hello,

    You need to put a language switcher in the menu, for example, and in this case, you can switch between translations. If you do not have a language switcher you can switch in admin of the page https://gyazo.com/939a3e535cbfc1068bbf0b339fdb26e8

    Best Regards

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.