Home Forums Basel – Premium Template (urgent) Language switch to default EN in checkout page

This topic contains 48 replies, has 4 voices, and was last updated by Artem Temos Artem Temos 4 months, 1 week ago.

Viewing 19 posts - 31 through 49 (of 49 total)
  • Author
    Posts
  • #152501

    Hello,

    This issue did not relate to our theme. The problem was between WPML and Woocommerce. Now I have checked the new WPML version: when you add a product to cart and go to the checkout, checkout does not switch to the default language. WPML has fixed the issue.

    Best Regards

    #152503

    esthetis
    Customer

    Hi,

    By switching to other theme like storefront, the problem was fixed….Then I think it was related to your theme in some way

    #152524

    Hello,

    Now the problem has been fixed by WPML. Please check.

    Best Regards

    #157974

    esthetis
    Customer

    Sorry but the problem has not been fixed by WPML.

    Please check our staging in private

    By overwriting your code, the problme persits and this means it is related to your theme

    Private Content Hidden
    #158016

    Hello,

    Make sure you run the recent version of WPML set of plugins and update the site admin access, I have checked the front end and see the problem at your site.

    Best Regards

    #158018

    esthetis
    Customer

    Yes it is the last versions WPML, please take the time to check it in our staging

    #158102

    Hello,

    I am checking the issue on the Storefront theme and I see the same problem, stop the video on the 6th second and you will see that after adding a product from the French store, I get to English checkout. https://gyazo.com/2b0aeaa8429041ec7c12939e0399d078

    I am checking in my site which is on clean WordPress installation and has no other plugins and never had and when I am on the French store, I add product and get to the French checkout https://gyazo.com/40503990bb63cdebd11deaf6d487245e and you see the fields are in French.

    Please check on the Storefront now.

    Best Regards

    #158117

    esthetis
    Customer

    But as we have the latest version of WPML, this means that WPML has still not fix the problem?

    #158124

    Hello,

    I am not sure. You see as I told and shown it works properly on my testing site which is the clean installation without plugins. I suspect that the problem is caused by WPML Sticky Links or some other additional plugins which are not compatible with Woocommerce. And even when these plugins are deactivated the problem still remains. Try to reinstall all on the staging site and check again. Leave the plugins related to our theme and main WPML plugins: https://prnt.sc/pzy59p

    Best Regards

    #160536

    esthetis
    Customer

    Hi again,

    We have just update WPML and again the problem is not fixed.

    We still have to replace with the following:

    if (
    ! $is_admin || ( isset( $_POST[‘action’] ) && $_POST[‘action’] === ‘basel_ajax_add_to_cart’ ) || ( ‘admin.php’ === $pagenow && isset( $_GET[‘page’] ) && ‘wc-settings’ === $_GET[‘page’] )
    ) {
    // Translate shop page ids
    $this->add_filter_to_get_shop_translated_page_id();
    }

    #160622

    Hello,

    The problem occurs with Woocommerce Multilingual. We have submitted the notification again. Meanwhile, you can use the fixed code we have provided:
    Try to edit the file wp-content/plugins/woocommerce-multilingual/inc/class-wcml-store-pages.php and replace this code

    if (
    			! $is_admin ||
    			( 'admin.php' === $pagenow && isset( $_GET['page'] ) && 'wc-settings' === $_GET['page'] )
    		) {
    			// Translate shop page ids
    			$this->add_filter_to_get_shop_translated_page_id();
    		}

    with this one

    if (
    			! $is_admin || ( isset( $_POST['action'] ) && $_POST['action'] === 'woodmart_ajax_add_to_cart' ) || ( 'admin.php' === $pagenow && isset( $_GET['page'] ) && 'wc-settings' === $_GET['page'] )
    		) {
    			// Translate shop page ids
    			$this->add_filter_to_get_shop_translated_page_id();
    		}

    as shown in the screenshot http://prntscr.com/pauyvg

    Kind Regards

    #165215

    esthetis
    Customer

    Hi again,

    Please fix the issue that the customers are calling us about the problem.

    The problem lasts for many months now.

    For each WPML update we have to take attention to replace the right code.

    Please fix it now.

    regards

    #165219

    We have contact WPML a few times about the issue. Please, report this from your side as well. We are not able to fix this in our theme since it is not our theme bug.

    #167632

    Hello,

    Please, send us your website access so we can replicate the issue while working with WPML team. We don’t have this problem on our website.

    Kind Regards

    #167637

    esthetis
    Customer

    below access to staging

    Private Content Hidden
    #167872

    Try to enable this option in WPML configuration https://gyazo.com/a5a7b012da02f9a9d5c310ce9795ac48

    #168000

    Have you tried to enable the option? Please, notify us about the result.

    Thank you in advance.

    #168006

    esthetis
    Customer

    Hi,

    I thought you have tested it before.

    I have to wait for the update in order to see if it fix the problem.

    Meanwhile, please try to restore the origianl WPML file and enable the option.

    REgards

    #168854

    Try to reinstall WPML from scratch and check the issue with this option turned on/off.

Viewing 19 posts - 31 through 49 (of 49 total)

You must be logged in to reply to this topic.