Home Forums WoodMart support forum Woo Custom Stock Status conflict with WoodMart

Woo Custom Stock Status conflict with WoodMart

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #482166

    techiebraj
    Participant

    Hi,

    I am using Woo Custom Stock Status plugin to show stock status on Single Product & Product Archive, the plugin link is https://wordpress.org/plugins/woo-custom-stock-status/

    My issue is WoodMart is adding there style to this plugin STOCK STATUS widget, what to disable or do in WoodMart so that it will not conflict with this plugin style?

    According to plugin SS, it should shows stock status like this, https://prnt.sc/Gqa1kB-JrKuB
    But it shows like this in product archive: https://prnt.sc/86UvEX6XisD7
    And in single product it also looks different: https://prnt.sc/6hGp9abfXp5D

    Thanks!

    #482229

    Luke Nielsen
    Keymaster

    Hello,

    Is there any chance that you could give me access to the dashboard area so I can have a look at the settings on your website, please?

    Kind Regards

    #482466

    techiebraj
    Participant

    Hi,

    Sure, i have attached the login details in private area πŸ™‚

    Note: This a a production site with busy traffic, make sure you handle it with care and make a log of what you did πŸ™‚

    Thanks!

    • This reply was modified 11 months ago by techiebraj.
    #482633

    Luke Nielsen
    Keymaster

    Hello,

    Seems that access is limited, you can check it on your side. Also, before checking, please navigate to Theme Settings -> Performance -> CSS and define this rule: https://take.ms/UW7Qf in the “Styles never load” field, then recheck the issue.

    Kind Regards

    #483358

    techiebraj
    Participant

    Hi,

    I did that and added that CSS never loads, but it seems the issue is still not fixed, although now single product stock status elements are now the same as the product grid on the homepage.

    Added new login details so that you could check yourself πŸ™‚

    Thanks!

    #483836

    Luke Nielsen
    Keymaster

    Hello,

    I have checked how it looks on the default theme: https://monosnap.com/file/wDumJla1kcLGQL0gbFS19AzAYLIRxa , as you can see, there is all the same besides the image near the text.

    Kind Regards

    #483908

    techiebraj
    Participant

    Hey,

    Thanks for looking. Do you know why the image or emoji not loading?

    Thanks!

    #483969

    Luke Nielsen
    Keymaster

    Hello,

    Please add the below code in Theme Settings -> Custom CSS. Then clear the browser/server/website cache and recheck the issue.

    .product-grid-item .woo-custom-stock-status.s_in_stock_color:before {
    	content: "\f118";
    	font-family: "Font Awesome 5 Free";
    	font-weight: 900;
    	margin-right: 7px;
    }

    Kind Regards

    #483970

    techiebraj
    Participant

    Hi,

    It works πŸ™‚

    Just for curiosity, I want to know what the issue, so that I can go to the root of this to fix this without adding this πŸ™‚

    Thanks!

    #483983

    Luke Nielsen
    Keymaster

    Hello,

    It’s not a bug in the theme.

    1. Storefront has such a design and our theme has a different design.

    2. Storefront uses font-awesome for showing that icon but we use our own font for “in stock”.

    So the above code just helps you to show the same icon as in the default theme.

    Kind Regards

    #484012

    techiebraj
    Participant

    Hi,

    I got it; I guess you use tick marks as in stock icon, if you read the first message of this conv, i.e.

    But it shows like this in the product archive: https://prnt.sc/86UvEX6XisD7
    And in single product, it also looks different: https://prnt.sc/6hGp9abfXp5D

    So why your in-stock icon was not loading on the product archive page? If this works then I am also happy with the tick icon, but it should work everywhere.

    Thanks!

    #484019

    Luke Nielsen
    Keymaster

    Hello,

    In our theme, that icon is available on the archive page as well. I have checked your website and on both pages (archive and single) that icon is hidden: https://take.ms/NsVGN, https://take.ms/rSI3Z

    It means that your website is cached therefore clear the website/browser/server cache and recheck it.

    On the product grid, you don’t have our icon because of 2 reasons:

    1. Some third-party plugins affect it and therefore our icon is hidden.

    2. Also, you have disabled styles for “insock” field.

    So first of all, I suggest navigating to Theme Settings -> Performance -> CSS and removing previous changes: https://take.ms/UW7Qf in the β€œStyles never load” field (which means delete that rule from the screenshot). Then clear all cache on your website and check again, if there the icon will not be available, let me know and I will give you a custom code that will work with your third-party plugin.

    Kind Regards

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)