Home Forums WoodMart – Premium Template 504 Gateway Time-out after installing SSL

This topic contains 40 replies, has 3 voices, and was last updated by Artem Temos Artem Temos 2 months, 3 weeks ago.

Viewing 30 posts - 1 through 30 (of 41 total)
  • Author
    Posts
  • #72692

    pierre
    Customer

    Hi,
    i have a 504 Gateway Time-out after installing SSL.
    probleme came after installing childtheme, then data import.
    site adresse: virtuadev.fr

    thanx for help

    Private Content Hidden
    • This topic was modified 3 months ago by  pierre.
    #72694

    pierre
    Customer

    i modified the .htaccess via the plugin ReallySimpleSSL and now obtain this:
    i confirm that without your theme and wp 2017 theme all is working well.


    Options:
    * htaccess redirect
    * WordPress redirect
    * Mixed content fixer
    SERVER: apache
    SSL is enabled for this site
    ** Detecting configuration **
    plugin version: 3.0.5
    Already on SSL, start detecting configuration
    Opening testpage to check server configuration: https://virtuadev.fr/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    test page url, enter in browser to check manually: https://virtuadev.fr/wp-content/plugins/really-simple-ssl/ssl-test-page.php
    Could not open testpage cURL error 28: Connection timed out after 5001 milliseconds
    SSL type: LOADBALANCER
    ** Configuring SSL **
    testing htaccess rules…
    test page url, enter in browser to check manually: https://virtuadev.fr/wp-content/plugins/really-simple-ssl/testssl/loadbalancer/ssl-test-page.html
    htaccess rules test failed with error: cURL error 28: Connection timed out after 5000 milliseconds
    checking if .htaccess can or should be edited…
    .htaccess does not contain default Really Simple SSL redirect
    retrieving redirect rules
    converting siteurl and homeurl to https

    #72707

    Hello,

    Could you please disable all plugins that are not related to our theme and provide us your admin access so we can check it?

    Thank you in advance

    #72716

    pierre
    Customer

    Hi,
    desactivate the only one plugin was Really Simple SSL

    Private Content Hidden
    • This reply was modified 3 months ago by Artem Temos Artem Temos.
    #72720

    We can’t access with the password you sent. Please, check it.

    #72722

    pierre
    Customer

    try this new one :

    Private Content Hidden
    • This reply was modified 3 months ago by Artem Temos Artem Temos.
    #72728

    500 Internal Error says about some issue on the server and can be caused by different things. Anyway, to understand its nature you need to see your server error logs or enable PHP error display on the website. If you can’t do this, you need to contact your hosting provider for help in this question. Here is an article that may help you understand the error better http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-internal-server-error-in-wordpress/

    #72741

    pierre
    Customer

    Here my last logs: https://logs.cluster026.hosting.ovh.net/virtuadev.fr/logs/logs-08-2018/error/virtuadev.fr-14-08-2018.log.gz
    if could help any issues..

    But anyway i’m sure that the problem comes from when we do data import. I installed many times your theme and almost each time it had bugs during import. All site was ok before that data import.

    Any solution to unistall data without re-install all stuff?
    Tanx

    • This reply was modified 3 months ago by  pierre.
    #72745

    pierre
    Customer

    indeed, i just changed Demo versions by selectiong different ones.. and now its running ok.
    So its really your installation of demo template et datas that is not really stable.

    –> electronics demo version is instable (tried many time before)

    • This reply was modified 3 months ago by  pierre.
    #72748

    We can’t download error logs, it requires password.

    #72750

    pierre
    Customer

    here to donwload: https://virtuadev.fr/wp-content/uploads/2018/08/logs-14-aug.txt
    the 14 aug i did a full new install on my server from scratch, activate ssl, all was ok until install data import.

    #72751

    The problem seems to be caused by your categories menu. Try to create a new categories menu and your own items inside them.

    #72841

    pierre
    Customer

    …”your categories menu”? i did not create any menu, products, items at all, all is from YOUR theme demo datas import.
    so, i try to change as you said the menu … but still 504 Gateway Time-out bug.

    any clues on how to delete all your datas without re install all stuff from scratch?

    • This reply was modified 3 months ago by  pierre.
    #72842

    Yes, it is our dummy content menu. But some conflict may appear with your current content or whatever. Anyway, just create your categories menu from scratch because you will not use our sample categories.

    #72857

    pierre
    Customer

    arg!
    i delete all website, restart a full installation and this is your dummy data import that makes the bug of 504 Gateway Time-out !!!
    Actually its because your dummy data import does not support HTTPS, without it, it works.

    so…

    #72862

    Did you try to create your own categories menu as per our advice?

    #72868

    pierre
    Customer

    ..so please help! i really need you dummy content and electronics demos theme running.
    i just want to make test on it and make changes after..
    so please create for me some “new categories menu from scratch” and apply on menu because i don’t understand how to fix it, there is menu catgeorie on theme the is not installed…

    Private Content Hidden
    #72876
    #72891

    pierre
    Customer

    my website is dead (virtuadev.fr = 504) and now you can access https://virtuadev.fr/wp-admin/

    thanx

    #72895
    #72897

    pierre
    Customer

    Yep sorry but i spent 24hours to make it works. I’m full now.
    i can’t understand how to change a menu that doesn’t exist beacuse the theme is not installed beacuse of bug…
    ok, show me you can make works thios theme with https:

    Private Content Hidden
    • This reply was modified 3 months ago by  pierre.
    • This reply was modified 3 months ago by  pierre.
    #72904

    But it is not a bug, and our theme is fully compatible with HTTPs. You can check how it works on our demo for example. We didn’t change anything because we still can’t access your dashboard https://gyazo.com/2942d7ea148f9dbc95bde19ae9a76147
    You leave a bad review while we even don’t have a chance to help you to resolve the problem. We are struggling to replace our demo categories menu but you don’t give us the admin access. How can we resolve this issue? All you need to is to replace the menu with your own items.

    #73060

    Hello there,

    As we can see, your website is working now. Have you resolved the issue? Do you have any extra questions that we may help you with?

    We would be very happy if we can resolve this issue and you will remove your negative review.

    Waiting for your response.
    Xtemos studio.

    #73090

    pierre
    Customer

    hi,
    i’ll delete my negative review until this link works: this link https://virtuadev.fr/boutique/clocks/panton-tunior-chair/ works for u?
    thanx

    Pierre

    #73091

    Hello,

    It loads just a half of the page. Please, provide us your admin and FTP access so we can see what is wrong there.

    Thank you.

    #73147

    pierre
    Customer
    Private Content Hidden
    #73170

    Hello,

    We don’t see your WordPress installation with this FTP account https://gyazo.com/6e816088231ceca9f0dc6b2c57f2ce6d

    And we can’t enter your dashboard because of this https://gyazo.com/830fdd4e02de8d96dd4bda4f36641554

    Regards

    #73313

    gueshu
    Customer

    I guess you are using OVH as a host provider…

    I think I had the same problem.

    Look at my post:

    https://xtemos.com/forums/topic/error-504-with-some-demo-versions/

    After doing the import of content you need to modify the megamenus in the category menu that contain info box with school, the problem seems to come from that.
    Or as the support said, you need to create your own menu with clean fresh data instead of dummy content.

    The trouble is other pages use info boxes with school (some single products) and you need to edit them too.

    I hope it is clear. But I am sure your website will work, it was the major problem I faced too, but now it is smooth…

    Private Content Hidden
    #73314

    gueshu
    Customer

    I am fairly confident that if you delete the info boxes in the description of the product that can’t load (panton tunior chair), it will work as it is using the info box with SVG that is probably the source of your problem.

    I am sure when u make your own products you won’t have these problems.
    Then consider changing your review, this team is the greatest I have worked with and this theme is incredible value for money, nothing comes near it. If you had searched in the forum for 504 errors you would probably have found my post. This forum is a great source of information, better than all the other themes I have worked with.

    Are you using OVH as a host by the way?

    Private Content Hidden
    #73316

    gueshu
    Customer

    I can’t edit my first post and I realise there are mistakes due to autocorrect on my phone…

    When you see “info boxes with school” it was meant to be “with SVG” this format seems to create troubles at least with my host provider (using the website locally on my computer, I don’t have the problem).

    Private Content Hidden
Viewing 30 posts - 1 through 30 (of 41 total)

You must be logged in to reply to this topic.