Home Forums WoodMart – Premium Template customs font ( Persian fonts ) and RTL

Tagged: ,

This topic contains 3 replies, has 2 voices, and was last updated by Elise Noromit Elise Noromit 1 month, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #217321
    hessam
    hessam
    Customer

    hi ,
    i just bought woodmart theme , and search in topics about my issues .
    my web site , need Persian font and also need RTL default load .
    1. for change the font i just search in forums , and just see some code , for change the font . but was for years ago , i just check the documentation and see, new feature about add new customs font by customers , which one we do ? by code or new way to import Persian font .
    2.for the RTL , is there any file ready and confirmed by Xtemos for the RTL version site , to add for style.css in?

    #217339

    Hello,

    Thank you very much for choosing our theme and for contacting us.

    Our theme RTL ready. As soon as you set RTL language in the Dashboard > Settgins > General, the site would switch to RTL automatically.

    You can upload any custom fonts, please find here how to do that: https://xtemos.com/docs/woodmart/faq-guides/upload-custom-fonts/

    You can set any font from the list in the Theme Settings > Typography.

    Best Regards

    #217354
    hessam
    hessam
    Customer

    hi , thanks
    for the new customs font solution , i did this but when i want to import font by media library , need security permission . i also change the way , and use c panel , import font files to the font Folder in theme folder . but not show in the list on typography .

    #217390

    In case you see “This file type cannot be uploaded due to security reasons.” Then follow the below steps:

    1. Add this line to the wp-config.php file: define( ‘ALLOW_UNFILTERED_UPLOADS’, true );

    2. Upload all font files formats

    3. Remove this line from wp-config.php file

    Best Regards.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.