Home Forums WoodMart – Premium Template Mobile menù and Newsletter Text Problem

This topic contains 13 replies, has 3 voices, and was last updated by Elise Noromit Elise Noromit 5 days, 19 hours ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #106213

    maloneweb
    Customer

    Hello Sir,

    Please see the private content, i need help.

    1) If i add a text in the newsletter mailchimp form, the text doesnt appear in home widget, even the button form color doesnt change. Why?

    2) If you see my mobile menù, i need that the submenù of each item, should be open by tapping on the entire item and not only on the arrow, otherwise a lot of visitors doesnt see the submenus and they will think that the website doesnt work.

    3) in homepage, how i can have the bottom newsletter/contact block attached to the footer (without margin) ? how i can create an html block with that code to have it on all pages?

    Please can you give me a solution?

    Thanks and best regards

    Private Content Hidden
    #106283

    Hello,

    1. You can add only predefined elements http://prntscr.com/mhrekx If you want to add a text, use text block http://prntscr.com/mhrez9

    2. There is no option, unfortunately. It works only by clicking on the arrow.

    3. Create HTML block containing newsletter form and insert as per instructions https://xtemos.com/docs/woodmart/html-blocks-2/#main_footer

    Best Regards

    #106628

    maloneweb
    Customer

    Hello Sir,

    thanks for your reply, i resolved all but not the point 1.

    Please see my homepage now, in the pre-footer i have the newsletter form,

    i added the predefined elements “agree to terms” but it doesnt see and the form now have a bad graphic. I need it to agree with GDPR.

    Please tell me a solution, i give you the login data in a private reply.

    Thanks and best regards

    #106654

    Hello,

    Please refer the plugin documentation or support to configure the form correctly.

    Mail Chimp for WP has this form:

    <p>
    	<label>Email address: </label>
    	<input type="email" name="EMAIL" placeholder="Your email address" required />
    </p>
    
    <p>
    	<input type="submit" value="Sign up" />
    </p>

    And you can view the demo how it looks like https://woodmart.xtemos.com/

    Best Regards

    #106714

    maloneweb
    Customer

    Hello,

    thanks but the problem is not solved.

    I use this plugin on hundred of themes and i have the problem only with woodmart.

    The code of my form is this (is your same code but with italian translation and the “agree to terms” checkbox)

    <p>
    	<label>Indirizzo email: </label>
    	<input type="email" name="EMAIL" placeholder="Inserisci La Tua Email" required />
    </p>
    
    <p>
        <label>
            <input name="AGREE_TO_TERMS" type="checkbox" value="1" required=""> <a href="/informativa-sulla-privacy" target="_blank">Accetto la privacy policy</a>
        </label>
    </p>
    
    <p>
    	<input type="submit" value="Iscriviti" />
    </p>

    As you can see, the checkbox doesnt appear in the theme and the form doesnt work.

    Please give me a solution, thanks and regards

    #106756

    Hello,

    Please add this code to the Theme Settings > Custom CSS > Global:

    .mc4wp-form p:last-child label {
    	display: block;
    }
    
    body .mc4wp-form>div>p {
    		max-width: 100%;
    		flex-basis: 100%;
    		width: 100%;
    }

    Best Regards

    #106892

    maloneweb
    Customer

    Hi, unfortunately, also with this solution i dont resolve the problem.

    With the code and your custom css i have this result (space on top and the agree to terms checkbox continue to not appear): https://prnt.sc/mjfir0

    I have this code now (i want that the checkbox appear before the form but doesnt work):

    <p>
        <label>
            <input name="AGREE_TO_TERMS" type="checkbox" value="1" required=""> <a href="/informativa-sulla-privacy" target="_blank">Accetto la privacy policy</a>
        </label>
    </p>
    
    <p>
    	<label>Indirizzo email: </label>
    	<input type="email" name="EMAIL" placeholder="Inserisci La Tua Email" required />
    </p>
    
    <p>
    	<input type="submit" value="Iscriviti" />
    </p>
    
    I attach a last screenshot, i want to have this result: 

    https://prnt.sc/mjfiyo

    I pray you the give me a definitive solution: the websites must be GDPR Compliant and with the checkbox that doesnt appear i have problems with GDPR.

    Thanks and best regards

    #106913

    Hello,

    The provided code supposed the checkbox is located after the form. Please replace the code with this one:

    .mc4wp-form p:first-child label {
    	display: block;
    }
    
    body .mc4wp-form>div>p {
    		max-width: 100%;
    		flex-basis: 100%;
    		width: 100%;
    }

    You will get this result: http://prntscr.com/mjglzf

    Best Regards

    #106917

    maloneweb
    Customer

    Excuse me, but i dont think of became a stupid. I need a real solution to resolve the problem.

    If you are seasoned to give solutions to ignorant web designers that only import a demo content, please note the this is not my case. I dont mean that you are a stupid and i respect you for this wonderful wp-theme, but please help me seriously.

    With your solution i dont have the submit button inline with the input field, and i have a high blank space up to the contact call to action, how i can resolve the problem in this way?!?!? See the website now please.

    If my question is unresolvable, please tell me and i will find another solution.

    Thanks a lot and best regards

    • This reply was modified 6 days, 2 hours ago by  maloneweb.
    #106942

    Hi,

    To achieve the desired form look you first need to place submit button directly after input from without any wrappers. Try to use the following layout:

    <p class="custom-form-checkbox">
        <label>
            <input name="AGREE_TO_TERMS" type="checkbox" value="1" required=""> <a href="/informativa-sulla-privacy" target="_blank">Accetto la privacy policy</a>
        </label>
    </p>
    <p class="custom-form-input">
    	<label>Indirizzo email: </label>
    	<input type="email" name="EMAIL" placeholder="Inserisci La Tua Email" required />
    	<input type="submit" value="Iscriviti" />
    </p>

    After, try to replace the previous custom code with the following CSS code snippet in the custom CSS area in theme settings.

    body .mc4wp-form .custom-form-checkbox {
    	-ms-flex-preferred-size: 100%;
    	flex-basis: 100%;
    	width: 100%;
    }
    
    body .mc4wp-form .custom-form-checkbox label {
    	display: block;
    }
    
    body .mc4wp-form > div > p {
    		max-width: 100%;
    		flex-basis: 100%;
    		width: 100%;
    }
    
    body .mc4wp-form-basic input[type=email] {
    	max-width: 100%;
    }
    
    .mc4wp-form .custom-form-input {
    	display: flex;
    }
    
    @media (max-width: 768px) {
    	.mc4wp-form .custom-form-input {
    		display: block;
    	}
    	
    	.mc4wp-form .custom-form-input input[type="submit"] {
    		margin-top: 20px;
    	}
    }

    In a result, you will achieve the following look on the desktop (https://prnt.sc/mjjchc) and mobile devices (http://prntscr.com/mjjkfw).

    Regards

    #106950

    maloneweb
    Customer

    Thanks infinite for your solution, i have appreciate a lot and now the problem is solved.

    I have only a last question:

    – How i can “resize” the width of the input email field? i want it slightly smaller.

    In also, i have reduced of 20 pixel the margin between html block and footer widgets by adding a -20px to margin-bottom in row settings (custom html block).

    I have a notice for you: i have translated the theme in italian by editing the .po files, if you need i can send you so you can include it for new customers.

    Please let me know,

    thank and regards

    #106971

    Hi,

    Try to use the following code snippet to control the width of your input field. Change the “max-width: 400px” parameter to the desired number.

    .mc4wp-form .mc4wp-form-fields .custom-form-checkbox {
    	width: 100%;
    	flex-basis: 100%;
    	max-width: 100%;
    }
    
    .mc4wp-form-fields .custom-form-input {
    	max-width: 400px;
    }

    Thank you, but we do not distribute translations to our theme by default.

    Regards

    #106973

    maloneweb
    Customer

    Thanks infinite.

    I have really the last question: does the theme have an options to have a “sticky” sidebar?

    Please let me know, thanks and regards

    #106981

    Hello,

    Our theme does not have sticky sidebar option, however, you can make a sticky column http://prntscr.com/mjo96n and add a widgetized sidebar element http://prntscr.com/mjo9ky

    This, however, would not work on shop/category page.

    Best Regards

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.