Home Forums WoodMart – Premium Template Problems customizing login/register

This topic contains 15 replies, has 2 voices, and was last updated by Elise Noromit Elise Noromit 15 hours, 4 minutes ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #173504

    Ida
    Customer

    Hello,

    both in WordPress, Theme and Woocommerce configurations, it is not allowed to register a user before buying. It is disabled to register from my account.

    But in the menu, “Login/Register” appears, and I would like only “Login” to appear

    In addition, when pressing, the user has the option of Login, but below also the one of register. Although later you will not be able, it leads to a Login page.

    Please, could you help me make these two modifications?
    1- the word “/register” (/registrar-se) disappears in the menu
    2- that the possibility of “Registration” disappears on the access page to “my account”

    Please find below the screenshots attached.

    Thank you so much.
    Best regards,

    Private Content Hidden
    Attachments:
    You must be logged in to view attached files.
    #173611

    Hello,

    Woocommerce provide option to register a user. You can configure that in Woocommerce > Settings > Account and Privacy. You will find the option to show register form on My account page for not logged users.

    Best Regards

    #173992

    Ida
    Customer

    Hello,

    yes, that is what i set; in woo and in theme options, deactivate options to register in my account. Please find below the screenshots attached, this time is the correct one.

    Thank you so much,
    best regards,

    Attachments:
    You must be logged in to view attached files.
    #174021

    Hello,

    You need to enable this option https://prnt.sc/r3jq6k if you want a user to have the option to register in the Account page.

    Best Regards

    #174047

    Ida
    Customer

    Hello,

    it shows that English is not my language, I am trying to say, to do, just the opposite. I have configured everything so that the user cannot register in my account, but the possibility still appears. This is what I mean.

    Thank you very much.
    Best regards,

    #174101

    Hello,

    Enable the guest account and disable all the rest. Please refer the documentation https://docs.woocommerce.com/document/configuring-woocommerce-settings/

    Best Regards

    #174625

    Ida
    Customer

    Hello,

    I did as you say and done some more tests. The “register” option appears all the time in the menu bar. Also, the “register” option appears below the Login form, even if it is been disabled. But at least instead of the registration page, it follows to a login page.

    Perhaps it could be an issue of the theme. Please, may you follow up with this particular to try to help me with this problem?

    Thank you so.
    Best regards

    #174660

    Hello,

    Please provide valid site admin access to the private area the previous credentials are not workable.

    Best Regards

    #175184

    Ida
    Customer

    Hello,

    please find below the credentials.

    Thank you so
    Best regards,

    Private Content Hidden
    #175304

    Hello,

    I cannot log in with the credentials. If you have any blocking plugins or server configuration, please disable.

    Best Regards

    #175718

    Ida
    Customer

    Hello,

    i have no blocking plugins or server configuration to disable. The login is ok, also another xtemos support member used it, but please, find below the super admin access, i give you also this, in case you need more permissions as it is multisite.

    Please, let me know.
    Thanks & best,

    Private Content Hidden
    #175821

    Hello,

    You need this option https://prnt.sc/r6yijg to have been activated.

    In order to allow inserting a user name and password, you need to disable this https://prnt.sc/r6ykd2

    Best Regards

    #176284

    Ida
    Customer

    Hello,

    excuse me, but you keep explaining to me the opposite of what I want to ask. What I do not want is that the user can register without buying. I do not want the user to be able to register directly from my account, therefore, what I would like is that the “register” not be announced on the Web menu bar or on the login page to my account. Only the Login option should appear.

    Thank you very much for your kind attention.

    Best regards

    #176348

    Hello,

    Please enable this option https://prnt.sc/r7znii

    Best Regards

    #176364

    Ida
    Customer

    Hello,

    yes, this option is already enabled and the registration option in my account continues to appear on the Web. I also tried through the theme options, I can’t find a way to make this disappear …

    Thank you.
    Best regards,

    #176388

    Hello,

    Please check how it works on the Storefront page. This is Woocommerce functionality and out theme does not influence. Try to disable all other options. Leave only this enabled top option.

    Best Regards

Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.