Home Forums Basel – Premium Template Showing wrong result on shop page.

This topic contains 41 replies, has 3 voices, and was last updated by Artem Temos Artem Temos 3 days, 23 hours ago.

Viewing 30 posts - 1 through 30 (of 42 total)
  • Author
    Posts
  • #224841

    Hi,

    We’re having two problems.

    1. It shows 545 products within the first category. It should say 69, as you can see to the right. See image.

    2. On category page Leksaker > Gåcyklar it shows Visar 1–20 av 28 resultat, but using the infinite scroll feature doesn’t load the rest 8 products!

    Thanks!

    Private Content Hidden
    Attachments:
    You must be logged in to view attached files.
    #224845

    Also… it doesn’t update the counter in the top when infinit have loaded new items.
    It still says showing 1-20…

    #224862

    Hi again,

    It was associated with the a permalink plugin. So it loads products again.

    But it doesn’t update the counter in the top when new items have loaded…

    Still also, the 545 count is wrong.

    #224888

    Hello,

    Please deactivate all the plugins not related to the theme and switch the parent theme, check the issue, If the problem has gone, activate the plugins one by one, checking the issue to detect which one causes the problem.

    if the problem remains, even after the plugins deactivated leave the plugins to deactivated for us to check and provide your site admin access to the private area.

    If you cannot keep the site without the plugins confirm the permit for us to deactivate for the while of checking what may take up to 15 minutes.

    Best Regards

    #225591

    Hi,

    Ok I need to explain a bit more. We use WP All Import
    to do the product imports.

    So I disabled ALL plugins except:

    WP All Import Pro (Needed for import)
    WP All Import – WooCommerce Add-On Pro (Needed for import)
    WooCommerce
    XTEMOS Post Types plugin

    We have used WP All Import for manual imports, if we do this,
    the count is correct with 67. But if we run the import with
    a cron job it shows 542. I noticed if I do a Recount terms under
    WooCommerce > Status > Tools. It sets it back to 67..

    Ive been in contact with WP All Import, so we are working on it.

    But do you guys have ANY idea why this might be happening?

    Thanks!

    #225603

    Hello,

    You see this functionality does not relate to our theme. And we have not tested WP All Import plugin with our theme thus, for now, no idea why. Such an investigation is a time-consuming process and that is not covered by our support policy, that is why let’s wait for the solution which would be suggested by the plugin team.

    Best Regards

    #225660

    Hi,

    Thanks. Yes I do understand that. I will continue talk to them.

    But, the part with 1-20 not being updated when infinite scroll is used.
    Have a check on the link. Scroll down, infinite is loading, now
    scroll up and it still says 1-20…

    Private Content Hidden
    #225661

    Your demo site has the same problem…

    https://demo.xtemos.com/basel/shop/?infinit_scrolling

    #225668

    Hello,

    Even though you set the infinite scrolling, the page has the configured number of products shown on the page, and it is shown. This value is not updated.

    Best Regards

    #225726

    Hmm that is not that good…
    It should work like that.

    Anyway, I talked to WP All Import about the problem with wrong counts for products.

    This is what they said:

    “I copied your site to a local installation and was able to replicate the count issue by running the import via cron. However, if I disable your theme and then run the import via cron, the counts are correct after the import.

    You’ll have to ask your theme developer for help with this.”

    So there is obviously something wrong in the theme when using Cron.
    WP All Import is a very popular import plugin.

    #225752

    Hi again,

    Ive tried importing with Wp All Import using the twenty eleven wordpress
    theme and the product count for the first category in the list turns out correct.
    So. There is something wrong in your theme.

    Its only the first category that is affected by this, it adds
    a count for all products currently in woocommerce to that count.

    …I only want to find a solution so how can we reset the count for products
    so it show the correct count?

    If I go into categories in woocommerce admin, it says 67 products for
    the first category. So nothing is wrong there.

    What controls the widget product category?

    #225795

    Could you please send us a screenshot of the categories widget with a default WordPress theme where it says 67 instead of 541?

    #225837

    Hi again,

    I got a response from WP All Import.

    “Me >> I still don’t understand why it works when I do a manual import with the theme we are using. How can the imports differ?

    WP All >> A manual import performs operations as the logged in user that’s running the import. A cron job import is an anonymous user. So, the theme must be doing something differently based on whether the user that’s updating products is logged in or not.”

    Can this help in anyway?

    #225846

    Hi, ok have a look at the image.

    Attachments:
    You must be logged in to view attached files.
    #225928

    Please, switch to the default theme temporarily and send us your admin and FTP access so we can check what is wrong.

    #225944

    Hi,

    Thanks you so much!

    Private Content Hidden
    #225947
    #225967

    No where did you login. You are on the wrong domain.
    Im using a temp dev environment.

    Its not correct.

    See below.

    Private Content Hidden
    #225970

    On the default theme it also shows 541 products instead of 67 https://prnt.sc/ugw8xx

    #225972

    Yes! Because it is wrong.

    It combines all product into that category when we do a cron import.

    Something is probably messed up with the theme when a user is not logged in…when adding products and categories.

    #225973

    But why it is a problem with our theme if it doesn’t work well with other themes as well?

    #225974

    We did an import without Basel theme activated. Just running WP default theme.
    And it showed up 67 products. Which is correct. So something is wrong when we import having your theme activated, it then shows 541!

    #225975

    OK, please, provide us a step by step instruction how to run this import with the default theme and then do this with Basel so we can see the difference.

    #225978

    Ok. The import process runs correctly when we do a manual import.
    It is through Cron it doesn’t work. So. Probably the user not being logged in is causing this. It just a guess…

    For you to put all this up and run a cron job would be some effort…but if you would like to sure. Sorry, I cannot give you access to our cpanel..

    Just login, activate your theme. Then run it with WP All Import, on the lower left
    in main menu admin. Then run the one called _produkter only the other one is for variants.
    It will come out as 67… but if I run a cron on these. It shows 541.

    #225981

    Sorry, but we can’t fix the problem if we don’t have a mechanism to reproduce it. First, we have to run it a few times to see the problem. Then, we will need your files access and be able to run it a few more times to troubleshoot it.

    #226022

    Ok I see.

    Wouldn’t it just be easier to clear the product data and reproduce the count somehow?
    I mean, within WooCoomerce Categories it says 67, but on the page it says 541,
    how is that possible, where is that data stored or created?

    See below.

    Private Content Hidden
    #226030

    We tried to run the first cron job, waited 10 minutes but don’t see any changes. Could you please check from your side if it was run correctly?

    #226031

    It still runs..

    currently processing with cron
    Records Processed 340
    last activity 57 sekunder ago

    #226032

    I told you before to run the import manually first. So you see 67.
    Then do the cron, it will show 541.

    #226034

    Its finished.

    But because you used one of the default WP themes, it show correctly 67.

    Now, try run the cron with your theme active…

Viewing 30 posts - 1 through 30 (of 42 total)

The topic ‘Showing wrong result on shop page.’ is closed to new replies.